blob: 0fc0ca46ab8e1851627113260b0bbb0f8249053c [file] [log] [blame]
Yuxiao Zhangb7b564f2024-01-24 10:15:45 -08001SUMMARY = "Disable obmc-console while the customer's host OS is running"
2DESCRIPTION = "Disable obmc-console while an untrusted host OS is running"
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9
10SRC_URI += " \
11 file://disable-obmc-console.service \
12 file://disable_obmc_console.sh \
13"
14
15DEPENDS += "systemd"
16
17RDEPENDS:${PN}:append = " \
18 bash \
19 bare-metal-active \
20 "
21
22SYSTEMD_PACKAGES = "${PN}"
23SYSTEMD_SERVICE:${PN} = " \
24 disable-obmc-console.service \
25 "
26
27do_install:append() {
28 install -d ${D}${systemd_system_unitdir}
29 install -m 0644 ${WORKDIR}/disable-obmc-console.service ${D}${systemd_system_unitdir}
30 install -d -m0755 ${D}${libexecdir}
31 install -m0755 ${WORKDIR}/disable_obmc_console.sh ${D}${libexecdir}/
32}