Yuxiao Zhang | b7b564f | 2024-01-24 10:15:45 -0800 | [diff] [blame] | 1 | SUMMARY = "Disable obmc-console while the customer's host OS is running" |
| 2 | DESCRIPTION = "Disable obmc-console while an untrusted host OS is running" |
| 3 | PR = "r1" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://disable-obmc-console.service \ |
| 12 | file://disable_obmc_console.sh \ |
| 13 | " |
| 14 | |
| 15 | DEPENDS += "systemd" |
| 16 | |
| 17 | RDEPENDS:${PN}:append = " \ |
| 18 | bash \ |
| 19 | bare-metal-active \ |
| 20 | " |
| 21 | |
| 22 | SYSTEMD_PACKAGES = "${PN}" |
| 23 | SYSTEMD_SERVICE:${PN} = " \ |
| 24 | disable-obmc-console.service \ |
| 25 | " |
| 26 | |
| 27 | do_install:append() { |
| 28 | install -d ${D}${systemd_system_unitdir} |
| 29 | install -m 0644 ${WORKDIR}/disable-obmc-console.service ${D}${systemd_system_unitdir} |
| 30 | install -d -m0755 ${D}${libexecdir} |
| 31 | install -m0755 ${WORKDIR}/disable_obmc_console.sh ${D}${libexecdir}/ |
| 32 | } |