Yuxiao Zhang | ca818a3 | 2023-12-13 17:37:37 -0800 | [diff] [blame] | 1 | SUMMARY = "Systemd target for enable/disable ipmi in bare-metal setup" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 7 | SRC_URI += "file://gbmc-bare-metal-active.target" |
| 8 | S = "${WORKDIR}" |
| 9 | |
| 10 | DEPENDS += " \ |
| 11 | systemd \ |
| 12 | " |
| 13 | |
| 14 | inherit systemd |
| 15 | |
| 16 | SYSTEMD_SERVICE:${PN} += " \ |
| 17 | gbmc-bare-metal-active.target \ |
| 18 | " |
| 19 | |
| 20 | do_install() { |
| 21 | install -d -m0755 ${D}${systemd_system_unitdir} |
| 22 | install -m0644 ${WORKDIR}/gbmc-bare-metal-active.target ${D}${systemd_system_unitdir}/ |
| 23 | } |