blob: 181b7418875af68b36ca6a7690734dcb428a3897 [file] [log] [blame]
Yuxiao Zhangca818a32023-12-13 17:37:37 -08001SUMMARY = "Systemd target for enable/disable ipmi in bare-metal setup"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
7SRC_URI += "file://gbmc-bare-metal-active.target"
8S = "${WORKDIR}"
9
10DEPENDS += " \
11 systemd \
12 "
13
14inherit systemd
15
16SYSTEMD_SERVICE:${PN} += " \
17 gbmc-bare-metal-active.target \
18 "
19
20do_install() {
21 install -d -m0755 ${D}${systemd_system_unitdir}
22 install -m0644 ${WORKDIR}/gbmc-bare-metal-active.target ${D}${systemd_system_unitdir}/
23}