blob: 813c6ec4c89ebc3e12d15ed58f8366b65496f4d9 [file] [log] [blame]
Patrick Williamsda295312023-12-05 16:48:56 -06001SUMMARY = "Monocypher is an easy-to-use crypto library"
2DESCRIPTION = "Monocypher is an easy to use, easy to deploy, \
3auditable crypto library written in portable C. It approaches the size of TweetNaCl and the speed of libsodium."
4HOMEPAGE = "https://monocypher.org/"
5SECTION = "libs"
Patrick Williamsf52e3dd2024-01-26 13:04:43 -06006LICENSE = "BSD-2-Clause | CC0-1.0"
7LIC_FILES_CHKSUM = "file://LICENCE.md;md5=ff30a1c41dfd9e6fa559a9e45ee98302"
Patrick Williamsda295312023-12-05 16:48:56 -06008
Patrick Williamsf52e3dd2024-01-26 13:04:43 -06009SRC_URI = "https://monocypher.org/download/${BPN}-${PV}.tar.gz"
10SRC_URI[sha512sum] = "bf275d4c53ff94af6cdc723a4e002e9f080f4d1436c86c76bb37870b34807f1d7b32331d8ff8a1aeb369e946f3769021e03e63efac25b82efc5abf54dc084714"
Patrick Williamsda295312023-12-05 16:48:56 -060011
Patrick Williamsf52e3dd2024-01-26 13:04:43 -060012MIRRORS = "https://.*/.* https://github.com/LoupVaillant/Monocypher/releases/download/${PV}/${BPN}-${PV}.tar.gz "
13
14S = "${WORKDIR}/${BPN}-${PV}"
Patrick Williamsda295312023-12-05 16:48:56 -060015
Patrick Williams169d7bc2024-01-05 11:33:25 -060016CFLAGS += "-pedantic -Wall -Wextra -O3"
17EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'CFLAGS=${CFLAGS}' 'LIBDIR=${libdir}'"
Patrick Williamsda295312023-12-05 16:48:56 -060018
19do_compile() {
20 oe_runmake library
21}
22
23do_install() {
24 oe_runmake install-lib
25 oe_runmake install-pc
26}
27
28BBCLASSEXTEND = "native nativesdk"