blob: 6b4336eb80a483b3f0791357e5479d63725a6a76 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit gnomebase gettext systemd gobject-introspection bash-completion
11
12DEPENDS = "glib-2.0 libgudev libxslt-native dbus"
13
14SRCREV = "03f786ce66360d67c669f4f122f8aa458e6f01ea"
15SRC_URI = "git://gitlab.freedesktop.org/mobile-broadband/ModemManager.git;protocol=https;branch=mm-1-22"
16
17S = "${WORKDIR}/git"
18
19# strict, permissive
20MODEMMANAGER_POLKIT_TYPE ??= "permissive"
21
22PACKAGECONFIG ??= "vala mbim qmi \
23 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \
24"
25
26PACKAGECONFIG[at] = "-Dat_command_via_dbus=true"
27PACKAGECONFIG[systemd] = " \
28 -Dsystemdsystemunitdir=${systemd_unitdir}/system/, \
29 -Dsystemdsystemunitdir=no -Dsystemd_journal=false -Dsystemd_suspend_resume=false \
30"
31PACKAGECONFIG[polkit] = "-Dpolkit=${MODEMMANAGER_POLKIT_TYPE},-Dpolkit=no,polkit"
32# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
33PACKAGECONFIG[mbim] = "-Dmbim=true,-Dmbim=false -Dplugin_dell=disabled -Dplugin_foxconn=disabled,libmbim"
34# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
35PACKAGECONFIG[qmi] = "-Dqmi=true,-Dqmi=false,libqmi"
36PACKAGECONFIG[qrtr] = "-Dqrtr=true,-Dqrtr=false,libqrtr-glib"
37PACKAGECONFIG[vala] = "-Dvapi=true,-Dvapi=false"
38
39inherit upstream-version-is-even ${@bb.utils.contains('PACKAGECONFIG', 'vala', 'vala', '', d)}
40
41EXTRA_OEMESON = " \
42 -Dudevdir=${nonarch_base_libdir}/udev \
43 -Dqrtr=false \
44"
45
46FILES:${PN} += " \
47 ${datadir}/icons \
48 ${datadir}/polkit-1 \
49 ${datadir}/dbus-1 \
50 ${datadir}/ModemManager \
51 ${libdir}/ModemManager \
52 ${systemd_unitdir}/system \
53"
54
55SYSTEMD_SERVICE:${PN} = "ModemManager.service"