Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Python implementation of a sliding window memory map manager" |
| 2 | DESCRIPTION = "A pure Python implementation of a sliding memory map to \ |
| 3 | help unifying memory mapped access on 32 and 64 bit systems and to help \ |
| 4 | managing resources more efficiently." |
| 5 | HOMEPAGE = "http://github.com/gitpython-developers/GitPython" |
| 6 | SECTION = "devel/python" |
| 7 | LICENSE = "BSD-3-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | PYPI_PACKAGE = "smmap" |
| 13 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "8d79028ea6cc131da5eab099a5d95a998d43c6779956fffe3b455040911076da" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 15 | |
| 16 | RDEPENDS:${PN} += "${PYTHON_PN}-codecs \ |
| 17 | ${PYTHON_PN}-mmap \ |
| 18 | " |
| 19 | BBCLASSEXTEND = "native nativesdk" |