Andrew Geissler | 3e34fba | 2021-03-05 15:21:55 -0600 | [diff] [blame] | 1 | SUMMARY = "CircuitPython helper library provides higher level objects to control motors and servos." |
| 2 | HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_Motor" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b72678307cc7c10910b5ef460216af07" |
| 5 | |
| 6 | SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_Motor.git" |
| 7 | SRCREV = "2251bfc0501d0acfb96c0a43f4f2b4c6a10ca14e" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit setuptools3 |
| 12 | |
| 13 | DEPENDS += "python3-setuptools-scm-native" |
| 14 | |
| 15 | RDEPENDS_${PN} += " \ |
| 16 | python3-adafruit-blinka \ |
| 17 | python3-core \ |
| 18 | " |