Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 1 | # Allow checking of required and conflicting features |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 2 | # |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 3 | # xxx = [DISTRO,MACHINE,COMBINED] |
| 4 | # |
| 5 | # ANY_OF_xxx_FEATURES: ensure at least one item on this list is included |
| 6 | # in xxx_FEATURES. |
| 7 | # REQUIRED_xxx_FEATURES: ensure every item on this list is included |
| 8 | # in xxx_FEATURES. |
| 9 | # CONFLICT_xxx_FEATURES: ensure no item in this list is included in |
| 10 | # xxx_FEATURES. |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 11 | # |
| 12 | # Copyright 2019 (C) Texas Instruments Inc. |
| 13 | # Copyright 2013 (C) O.S. Systems Software LTDA. |
| 14 | |
| 15 | python () { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | if d.getVar('PARSE_ALL_RECIPES', False): |
| 17 | return |
| 18 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 19 | unused = True |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 20 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 21 | for kind in ['DISTRO', 'MACHINE', 'COMBINED']: |
| 22 | if d.getVar('ANY_OF_' + kind + '_FEATURES') is None and \ |
| 23 | d.overridedata.get('ANY_OF_' + kind + '_FEATURES') is None and \ |
| 24 | d.getVar('REQUIRED_' + kind + '_FEATURES') is None and \ |
| 25 | d.overridedata.get('REQUIRED_' + kind + '_FEATURES') is None and \ |
| 26 | d.getVar('CONFLICT_' + kind + '_FEATURES') is None and \ |
| 27 | d.overridedata.get('CONFLICT_' + kind + '_FEATURES') is None: |
| 28 | continue |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 29 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 30 | unused = False |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 31 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 32 | # Assume at least one var is set. |
| 33 | features = set((d.getVar(kind + '_FEATURES') or '').split()) |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 34 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 35 | any_of_features = set((d.getVar('ANY_OF_' + kind + '_FEATURES') or '').split()) |
| 36 | if any_of_features: |
| 37 | if set.isdisjoint(any_of_features, features): |
| 38 | raise bb.parse.SkipRecipe("one of '%s' needs to be in %s_FEATURES" |
| 39 | % (' '.join(any_of_features), kind)) |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 40 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 41 | required_features = set((d.getVar('REQUIRED_' + kind + '_FEATURES') or '').split()) |
| 42 | if required_features: |
| 43 | missing = set.difference(required_features, features) |
| 44 | if missing: |
| 45 | raise bb.parse.SkipRecipe("missing required %s feature%s '%s' (not in %s_FEATURES)" |
| 46 | % (kind.lower(), 's' if len(missing) > 1 else '', ' '.join(missing), kind)) |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 47 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 48 | conflict_features = set((d.getVar('CONFLICT_' + kind + '_FEATURES') or '').split()) |
| 49 | if conflict_features: |
| 50 | conflicts = set.intersection(conflict_features, features) |
| 51 | if conflicts: |
| 52 | raise bb.parse.SkipRecipe("conflicting %s feature%s '%s' (in %s_FEATURES)" |
| 53 | % (kind.lower(), 's' if len(conflicts) > 1 else '', ' '.join(conflicts), kind)) |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 54 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 55 | if unused: |
| 56 | bb.warn("Recipe inherits features_check but doesn't use it") |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 57 | } |