Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | inherit kernel-arch |
| 2 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 3 | # We do the dependency this way because the output is not preserved |
| 4 | # in sstate, so we must force do_compile to run (once). |
| 5 | do_configure[depends] += "make-mod-scripts:do_compile" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 6 | |
| 7 | export OS = "${TARGET_OS}" |
| 8 | export CROSS_COMPILE = "${TARGET_PREFIX}" |
| 9 | |
| 10 | # This points to the build artefacts from the main kernel build |
| 11 | # such as .config and System.map |
| 12 | # Confusingly it is not the module build output (which is ${B}) but |
| 13 | # we didn't pick the name. |
| 14 | export KBUILD_OUTPUT = "${STAGING_KERNEL_BUILDDIR}" |
| 15 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | export KERNEL_VERSION = "${@oe.utils.read_file('${STAGING_KERNEL_BUILDDIR}/kernel-abiversion')}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | KERNEL_OBJECT_SUFFIX = ".ko" |
| 18 | |
| 19 | # kernel modules are generally machine specific |
| 20 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 21 | |