Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | inherit python3-dir |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 2 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 3 | PYTHON="${STAGING_BINDIR_NATIVE}/python3-native/python3" |
| 4 | EXTRANATIVEPATH += "python3-native" |
| 5 | DEPENDS_append = " python3-native " |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 6 | |
| 7 | # python-config and other scripts are using distutils modules |
| 8 | # which we patch to access these variables |
| 9 | export STAGING_INCDIR |
| 10 | export STAGING_LIBDIR |
| 11 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 12 | # Packages can use |
| 13 | # find_package(PythonInterp REQUIRED) |
| 14 | # find_package(PythonLibs REQUIRED) |
| 15 | # which ends up using libs/includes from build host |
| 16 | # Therefore pre-empt that effort |
| 17 | export PYTHON_LIBRARY="${STAGING_LIBDIR}/lib${PYTHON_DIR}${PYTHON_ABI}.so" |
| 18 | export PYTHON_INCLUDE_DIR="${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}" |
| 19 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | # suppress host user's site-packages dirs. |
| 21 | export PYTHONNOUSERSITE = "1" |
| 22 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 23 | # autoconf macros will use their internal default preference otherwise |
| 24 | export PYTHON |