blob: 61f6b79dd7ff163e5527d1ce926cbfab99680512 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "IPv4 link-local address allocator"
2DESCRIPTION = "Zeroconf is a program that is used to claim IPv4 \
3link-local addresses. IPv4 link-local addresses are useful when setting \
4up ad-hoc networking between devices without the involvement of a either \
5a DHCP server or network administrator. \
6These addresses are allocated from the 169.254.0.0/16 address range and \
7are normally attached to each Ethernet device in your computer. \
8Addresses are assigned randomly by each host and, in case of collision, \
9both hosts (are supposed to) renumber."
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010HOMEPAGE = "http://www.progsoc.org/~wildfire/zeroconf/"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011LICENSE = "GPL-2.0-or-later"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4 \
13 file://zeroconf.c;beginline=1;endline=13;md5=a5bada96e1e34b08eb7446b28e2630b2"
14SECTION = "net"
15
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016
17SRC_URI = "http://www.progsoc.org/~wildfire/zeroconf/download/${BPN}-${PV}.tar.gz \
18 file://compilefix.patch \
Patrick Williamsddad1a12017-02-23 20:36:32 -060019 file://makefile-add-ldflags.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020 file://zeroconf-default \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021 file://debian-zeroconf \
22 file://0001-zeroconf-Rename-arp_op-to-avoid-namespace-conflicts-.patch \
23 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024
25SRC_URI[md5sum] = "bdafb16b008ebb5633e4e581f77821d2"
26SRC_URI[sha256sum] = "a8c74df127753e2310fa1e072f3c9ca44a404bb0bbce9cfec7a84c6dff8bec7b"
27
Patrick Williamsb542dec2023-06-09 01:26:37 -050028EXTRA_OEMAKE += "CPPFLAGS='${CFLAGS}'"
29
Patrick Williamsb48b7b42016-08-17 15:04:38 -050030do_install () {
31 install -d ${D}${sbindir}
32 install -d ${D}${sysconfdir}/network/if-up.d
33 install -d ${D}${sysconfdir}/default
34 install -c -m 755 ${S}/zeroconf ${D}${sbindir}/zeroconf
35 install -c -m 755 ${WORKDIR}/debian-zeroconf ${D}${sysconfdir}/network/if-up.d/zeroconf
36 install -c ${WORKDIR}/zeroconf-default ${D}${sysconfdir}/default/zeroconf
37}