Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools" |
| 2 | HOMEPAGE = "https://github.com/gperftools/gperftools" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a" |
| 5 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 6 | SRCREV = "180bfa10d7cb38e8b3784d60943d50e8fcef0dcb" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | SRC_URI = "git://github.com/gperftools/gperftools \ |
| 8 | file://0001-Support-Atomic-ops-on-clang.patch \ |
| 9 | file://0001-fix-build-with-musl-libc.patch \ |
| 10 | file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \ |
| 11 | file://disable_libunwind_aarch64.patch \ |
| 12 | file://sgidef.patch \ |
| 13 | " |
| 14 | |
| 15 | inherit autotools |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | # On mips, we have the following error. |
| 20 | # do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008 |
| 21 | # Segmentation fault (core dumped) |
| 22 | COMPATIBLE_HOST_mipsarch = "null" |
| 23 | COMPATIBLE_HOST_riscv64 = "null" |
| 24 | COMPATIBLE_HOST_riscv32 = "null" |
| 25 | |
| 26 | # Disable thumb1 |
| 27 | # {standard input}: Assembler messages: |
| 28 | # {standard input}:434: Error: lo register required -- `ldr pc,[sp]' |
| 29 | # Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed |
| 30 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 31 | ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm" |
| 32 | |
| 33 | PACKAGECONFIG ?= "libunwind static" |
| 34 | PACKAGECONFIG_remove_arm_libc-musl = "libunwind" |
| 35 | PACKAGECONFIG_remove_riscv64 = "libunwind" |
| 36 | PACKAGECONFIG_remove_riscv32 = "libunwind" |
| 37 | |
| 38 | PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind" |
| 39 | PACKAGECONFIG[static] = "--enable-static,--disable-static," |
| 40 | |
| 41 | PACKAGE_BEFORE_PN += "libtcmalloc-minimal" |
| 42 | FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}" |
| 43 | |
| 44 | # pprof tool requires Getopt::long and POSIX perl5 modules. |
| 45 | # Also runs `objdump` on each cpuprofile data file |
| 46 | RDEPENDS_${PN} += "binutils perl-module-getopt-long perl-module-posix" |
| 47 | |
| 48 | RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})" |
| 49 | |