blob: 662777b47385cc850147b9743cea96c38b8db268 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools"
2HOMEPAGE = "https://github.com/gperftools/gperftools"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a"
5
Andrew Geisslerd688a012020-09-18 13:36:00 -05006SRCREV = "180bfa10d7cb38e8b3784d60943d50e8fcef0dcb"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007SRC_URI = "git://github.com/gperftools/gperftools \
8 file://0001-Support-Atomic-ops-on-clang.patch \
9 file://0001-fix-build-with-musl-libc.patch \
10 file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \
11 file://disable_libunwind_aarch64.patch \
12 file://sgidef.patch \
13 "
14
15inherit autotools
16
17S = "${WORKDIR}/git"
18
19# On mips, we have the following error.
20# do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008
21# Segmentation fault (core dumped)
22COMPATIBLE_HOST_mipsarch = "null"
23COMPATIBLE_HOST_riscv64 = "null"
24COMPATIBLE_HOST_riscv32 = "null"
25
26# Disable thumb1
27# {standard input}: Assembler messages:
28# {standard input}:434: Error: lo register required -- `ldr pc,[sp]'
29# Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed
30ARM_INSTRUCTION_SET_armv5 = "arm"
31ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm"
32
33PACKAGECONFIG ?= "libunwind static"
34PACKAGECONFIG_remove_arm_libc-musl = "libunwind"
35PACKAGECONFIG_remove_riscv64 = "libunwind"
36PACKAGECONFIG_remove_riscv32 = "libunwind"
37
38PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
39PACKAGECONFIG[static] = "--enable-static,--disable-static,"
40
41PACKAGE_BEFORE_PN += "libtcmalloc-minimal"
42FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}"
43
44# pprof tool requires Getopt::long and POSIX perl5 modules.
45# Also runs `objdump` on each cpuprofile data file
46RDEPENDS_${PN} += "binutils perl-module-getopt-long perl-module-posix"
47
48RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})"
49