Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "free PDF library" |
| 2 | HOMEPAGE = "http://libharu.org" |
| 3 | DESCRIPTION = "libHaru is a library for generating PDF files. \ |
| 4 | It is free, open source, written in ANSI C and cross platform. " |
| 5 | |
| 6 | LICENSE = "Zlib" |
| 7 | LIC_FILES_CHKSUM = "file://README;md5=3ee6bc1f64d9cc7907f44840c8e50cb1" |
| 8 | |
| 9 | SRC_URI = "git://github.com/libharu/libharu.git;branch=2_3 \ |
| 10 | file://libharu-RELEASE_2_3_0_cmake.patch \ |
| 11 | " |
| 12 | |
| 13 | SRCREV = "4ae1d5f4c84459f130bf1b1ef4c5c330af8eca5d" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit cmake |
| 18 | DEPENDS += "libpng zlib" |
| 19 | |
| 20 | do_install_append() { |
| 21 | mkdir -p ${D}/${datadir}/libharu |
| 22 | mv ${D}/libharu ${D}/${datadir} |
| 23 | } |