Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A filesystem snapshot utility based on rsync" |
| 2 | HOMEPAGE = "http://www.rsnapshot.org" |
| 3 | BUGTRACKER = "https://sourceforge.net/projects/rsnapshot/" |
| 4 | SECTION = "console/network" |
| 5 | |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a" |
| 8 | |
| 9 | RDEPENDS_${PN} = "rsync \ |
| 10 | perl \ |
| 11 | perl-module-dirhandle \ |
| 12 | perl-module-cwd \ |
| 13 | perl-module-getopt-std \ |
| 14 | perl-module-file-path \ |
| 15 | perl-module-file-stat \ |
| 16 | perl-module-posix \ |
| 17 | perl-module-fcntl \ |
| 18 | perl-module-io-file \ |
| 19 | perl-module-constant \ |
| 20 | perl-module-overloading \ |
| 21 | " |
| 22 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 23 | SRCREV = "a9e29850fc33c503c289e245c7bad350eed746d9" |
| 24 | PV = "1.4.3+git${SRCPV}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 25 | |
| 26 | SRC_URI = "git://github.com/DrHyde/${BPN};branch=master;protocol=git \ |
| 27 | file://configure-fix-cmd_rsync.patch \ |
| 28 | " |
| 29 | |
| 30 | S = "${WORKDIR}/git" |
| 31 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | inherit autotools perlnative |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 33 | |
| 34 | # Fix rsnapshot.conf.default: |
| 35 | # don't inject the host path into target configs. |
| 36 | EXTRA_OECONF += "--without-cp \ |
| 37 | --without-rm \ |
| 38 | --without-du \ |
| 39 | --without-ssh \ |
| 40 | --without-logger \ |
| 41 | --without-rsync \ |
| 42 | ac_cv_path_PERL=${bindir}/perl \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 43 | ac_cv_path_MOUNT=${base_bindir}/mount \ |
| 44 | ac_cv_path_UMOUNT=${base_bindir}/umount \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 45 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 46 | |
| 47 | # Create 't/include.ac' before starting the autoreconf to fix configure |
| 48 | # error: configure.ac:302: file 't/include.ac' does not exist |
| 49 | do_configure_prepend(){ |
| 50 | saved_dir=`pwd` |
| 51 | cd ${S}; ./autogen.sh |
| 52 | cd ${saved_dir} |
| 53 | } |