Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Sets up distcc for compilation on the target device" |
| 2 | |
| 3 | LICENSE = "MIT" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 5 | |
| 6 | SRC_URI = "file://distcc.sh" |
| 7 | |
| 8 | S = "${WORKDIR}" |
| 9 | |
| 10 | # Default to the host machine for a running qemu session |
| 11 | DISTCC_HOSTS ?= "192.168.7.1" |
| 12 | |
| 13 | do_configure() { |
| 14 | sed -i "s%@DISTCC_HOSTS@%${DISTCC_HOSTS}%" distcc.sh |
| 15 | } |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${sysconfdir}/profile.d |
| 19 | install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/ |
| 20 | } |
| 21 | |
| 22 | RDEPENDS_${PN} = "distcc" |