Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 1 | SUMMARY = "PMU ROM for QEMU" |
| 2 | DESCRIPTION = "The ZynqMP PMU ROM for QEMU emulation" |
| 3 | HOMEPAGE = "http://www.xilinx.com" |
| 4 | SECTION = "bsp" |
| 5 | |
| 6 | # The BSP package does not include any license information. |
| 7 | LICENSE = "Proprietary" |
| 8 | LICENSE_FLAGS = "xilinx" |
| 9 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28" |
| 10 | |
| 11 | COMPATIBLE_MACHINE = "zcu102-zynqmp" |
| 12 | |
| 13 | inherit deploy |
| 14 | inherit xilinx-fetch-restricted |
| 15 | |
| 16 | BSP_NAME = "xilinx-zcu102" |
| 17 | BSP_FILE = "${BSP_NAME}-v${PV}-final.bsp" |
| 18 | SRC_URI = "https://www.xilinx.com/member/forms/download/xef.html?filename=${BSP_FILE};downloadfilename=${BSP_FILE}" |
| 19 | SRC_URI[md5sum] = "cea5f11761e7f38cbfcf0a07a19094e0" |
| 20 | SRC_URI[sha256sum] = "7ac0ac3a5fb7dd162c0a922c66edb33b5737955ef6570a1a1d3b15b4344f7cc1" |
| 21 | |
| 22 | INHIBIT_DEFAULT_DEPS = "1" |
| 23 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 24 | |
| 25 | do_compile() { |
| 26 | # Extract the rom into workdir |
| 27 | tar -xf ${WORKDIR}/${BSP_FILE} ${BSP_NAME}-${PV}/pre-built/linux/images/pmu_rom_qemu_sha3.elf -C ${S} |
| 28 | # tar preserves the tree, so use find to get the full path and move to to the root |
| 29 | for i in $(find ${S} -type f -name *.elf); do mv $i ${S}/pmu-rom.elf; done |
| 30 | } |
| 31 | |
| 32 | do_install() { |
| 33 | : |
| 34 | } |
| 35 | |
| 36 | do_deploy () { |
| 37 | install -D ${S}/pmu-rom.elf ${DEPLOYDIR}/pmu-rom.elf |
| 38 | } |
| 39 | |
| 40 | addtask deploy before do_build after do_install |
| 41 | |