Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 1 | DESCRIPTION = "REALTIMEKIT Realtime Policy and Watchdog Daemon" |
| 2 | LICENSE = "GPL-3.0-only & BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a8e768468b658b3ed44971b53d4a6716" |
| 4 | |
| 5 | SRC_URI = "git://github.com/heftig/rtkit.git;protocol=https;branch=master" |
| 6 | |
| 7 | SRCREV = "b9169402fe5e82d20efb754509eb0b191f214599" |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit meson pkgconfig features_check useradd |
| 11 | |
| 12 | REQUIRED_DISTRO_FEATURES = "polkit" |
| 13 | |
| 14 | DEPENDS = "dbus libcap polkit xxd-native" |
| 15 | |
| 16 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 17 | PACKAGECONFIG[systemd] = ",,systemd" |
| 18 | |
| 19 | USERADD_PACKAGES = "${PN}" |
| 20 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --shell /bin/nologin rtkit" |
| 21 | |
| 22 | FILES:${PN} += "${libdir} ${datadir}" |
| 23 | |