blob: 8344015204b18f66d398fc751b014baec54b95b9 [file] [log] [blame]
Andrew Geissler5082cc72023-09-11 08:41:39 -04001SUMMARY = "A liberally licensed VNC server library"
2DESCRIPTION = "This is a liberally licensed VNC server library that's intended to be fast and neat."
3HOMEPAGE = "https://github.com/any1/neatvnc"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94fc374e7174f41e3afe0f027ee59ff7"
6
7SRC_URI = "git://github.com/any1/neatvnc;branch=master;protocol=https"
8
9SRCREV = "8b3dc1ae6099dcfa73aec3ae11df2fdc58540d14"
10
11PV = "0.6.0+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "libdrm pixman aml zlib"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[tls] = "-Dtls=enabled,-Dtls=disabled,gnutls"
19PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,libjpeg-turbo"
20PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false,libpng"
21PACKAGECONFIG[benchmarks] = "-Dbenchmarks=true,-Dbenchmarks=false,libpng"
22
23PACKAGE_BEFORE_PN += "${PN}-examples"
24ALLOW_EMPTY:${PN}-examples = "1"
25FILES:${PN}-examples = "${bindir}"
26
27NEATVNC_EXAMPLES = "draw png-server"
28
29inherit meson pkgconfig
30
31do_install:append () {
32 if ${@bb.utils.contains('PACKAGECONFIG', 'examples', 'true', 'false', d)}; then
33 install -d ${D}${bindir}
34 for bin in ${NEATVNC_EXAMPLES}; do
35 install -m 0755 ${B}/examples/$bin ${D}${bindir}
36 done
37 fi
38}
39
40BBCLASSEXTEND = "native"