Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Multiplexing terminal manager" |
| 2 | DESCRIPTION = "Screen is a full-screen window manager \ |
| 3 | that multiplexes a physical terminal between several \ |
| 4 | processes, typically interactive shells." |
| 5 | HOMEPAGE = "http://www.gnu.org/software/screen/" |
| 6 | BUGTRACKER = "https://savannah.gnu.org/bugs/?func=additem&group=screen" |
| 7 | |
| 8 | SECTION = "console/utils" |
| 9 | |
| 10 | LICENSE = "GPLv3+" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 12 | file://screen.h;endline=26;md5=3971142989289a8198a544220703c2bf" |
| 13 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | DEPENDS = "ncurses virtual/crypt \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
| 16 | RDEPENDS_${PN} = "base-files" |
| 17 | |
| 18 | SRC_URI = "${GNU_MIRROR}/screen/screen-${PV}.tar.gz \ |
| 19 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'file://screen.pam', '', d)} \ |
| 20 | file://Remove-redundant-compiler-sanity-checks.patch \ |
| 21 | file://Provide-cross-compile-alternatives-for-AC_TRY_RUN.patch \ |
| 22 | file://Skip-host-file-system-checks-when-cross-compiling.patch \ |
| 23 | file://Avoid-mis-identifying-systems-as-SVR4.patch \ |
| 24 | file://0002-comm.h-now-depends-on-term.h.patch \ |
| 25 | file://0001-fix-for-multijob-build.patch \ |
| 26 | file://0001-configure.ac-fix-configure-failed-while-build-dir-ha.patch \ |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 27 | file://0001-Remove-more-compatibility-stuff.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 28 | " |
| 29 | |
| 30 | SRC_URI[md5sum] = "a0f529d3333b128dfaa324d978ba73a8" |
| 31 | SRC_URI[sha256sum] = "1b6922520e6a0ce5e28768d620b0f640a6631397f95ccb043b70b91bb503fa3a" |
| 32 | |
| 33 | inherit autotools texinfo |
| 34 | |
| 35 | PACKAGECONFIG ??= "" |
| 36 | PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter," |
| 37 | |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame^] | 38 | EXTRA_OECONF = "--with-pty-mode=0620 --with-pty-group=5 --with-sys-screenrc=${sysconfdir}/screenrc \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 39 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)}" |
| 40 | |
| 41 | do_install_append () { |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame^] | 42 | install -D -m 644 ${S}/etc/etcscreenrc ${D}/${sysconfdir}/screenrc |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 43 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then |
| 44 | install -D -m 644 ${WORKDIR}/screen.pam ${D}/${sysconfdir}/pam.d/screen |
| 45 | fi |
| 46 | } |
| 47 | |
| 48 | pkg_postinst_${PN} () { |
| 49 | grep -q "^${bindir}/screen$" $D${sysconfdir}/shells || echo ${bindir}/screen >> $D${sysconfdir}/shells |
| 50 | } |
| 51 | |
| 52 | pkg_postrm_${PN} () { |
| 53 | printf "$(grep -v "^${bindir}/screen$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells |
| 54 | } |