Matt Spinler | aca1b15 | 2017-03-10 15:08:56 -0600 | [diff] [blame] | 1 | SUMMARY = "OpenPower procedure control" |
| 2 | DESCRIPTION = "Provides procedures that run against the host chipset" |
| 3 | PR = "r1" |
Patrick Venture | 8eb2361 | 2018-10-02 19:14:43 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Matt Spinler | 37619cc | 2017-10-04 13:07:06 -0500 | [diff] [blame] | 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 7 | |
Matt Spinler | aca1b15 | 2017-03-10 15:08:56 -0600 | [diff] [blame] | 8 | S = "${WORKDIR}/git" |
| 9 | |
Andrew Geissler | 643013c | 2018-11-20 03:20:12 +0000 | [diff] [blame] | 10 | inherit autotools obmc-phosphor-utils pkgconfig pythonnative |
| 11 | inherit systemd |
Matt Spinler | aca1b15 | 2017-03-10 15:08:56 -0600 | [diff] [blame] | 12 | |
Matt Spinler | 37619cc | 2017-10-04 13:07:06 -0500 | [diff] [blame] | 13 | SRC_URI += "git://github.com/openbmc/openpower-proc-control" |
Andrew Geissler | 6aafc64 | 2019-12-12 09:10:40 +0000 | [diff] [blame] | 14 | SRCREV = "b181d3bb878f986598751ddb1875577b7ba65a39" |
Matt Spinler | 20c9cd0 | 2017-09-18 15:52:40 -0500 | [diff] [blame] | 15 | |
| 16 | DEPENDS += " \ |
| 17 | autoconf-archive-native \ |
| 18 | phosphor-logging \ |
| 19 | phosphor-dbus-interfaces \ |
| 20 | openpower-dbus-interfaces \ |
| 21 | " |
Andrew Jeffery | 20973e0 | 2019-08-07 10:38:11 +0930 | [diff] [blame] | 22 | |
| 23 | # For libpdbg, provided by the pdbg package |
| 24 | DEPENDS += "pdbg" |
| 25 | |
Andrew Geissler | 643013c | 2018-11-20 03:20:12 +0000 | [diff] [blame] | 26 | TEMPLATE = "pcie-poweroff@.service" |
| 27 | INSTANCE_FORMAT = "pcie-poweroff@{}.service" |
| 28 | INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}" |
| 29 | SYSTEMD_PACKAGES = "${PN}" |
| 30 | SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}" |
Lakshminarayana R. Kammath | 4378a3f | 2019-06-11 12:37:25 -0500 | [diff] [blame] | 31 | |
| 32 | SYSTEMD_SERVICE_${PN} += " \ |
| 33 | xyz.openbmc_project.Control.Host.NMI.service \ |
Lakshminarayana R. Kammath | 4378a3f | 2019-06-11 12:37:25 -0500 | [diff] [blame] | 34 | " |