Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "An L2TP client/server, designed for VPN use." |
| 2 | DESCRIPTION = "OpenL2TP is an open source L2TP client / server, written \ |
| 3 | specifically for Linux. It has been designed for use as an enterprise \ |
| 4 | L2TP VPN server or in commercial, Linux-based, embedded networking \ |
| 5 | products and is able to support hundreds of sessions, each with \ |
| 6 | different configuration. It is used by several ISPs to provide \ |
| 7 | L2TP services and by corporations to implement L2TP VPNs." |
| 8 | HOMEPAGE = "http://www.openl2tp.org/" |
| 9 | SECTION = "net" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | |
| 11 | # cli and usl use license LGPL-2.1 |
| 12 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=e9d9259cbbf00945adc25a470c1d3585 \ |
| 14 | file://LICENSE;md5=f8970abd5ea9be701a0deedf5afd77a5 \ |
| 15 | file://cli/LICENSE;md5=9c1387a3c5213aa40671438af3e00793 \ |
| 16 | file://usl/LICENSE;md5=9c1387a3c5213aa40671438af3e00793 \ |
| 17 | " |
| 18 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | DEPENDS = "popt flex readline rpcsvc-proto-native bison-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 21 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 22 | file://Makefile-modify-CFLAGS-to-aviod-build-error.patch \ |
| 23 | file://openl2tp-simplify-gcc-warning-hack.patch \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 24 | file://Makefile-obey-LDFLAGS.patch \ |
| 25 | file://0001-test-pppd_dummy.c-Fix-return-value.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 26 | file://0001-Use-1-instead-of-WAIT_ANY.patch \ |
| 27 | file://0002-cli-include-fcntl.h-for-O_CREAT-define.patch \ |
| 28 | file://0003-cli-Define-_GNU_SOURCE-for-getting-sighandler_t.patch \ |
| 29 | file://0001-l2tp_api-Included-needed-headers.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 30 | file://openl2tpd-initscript-fix.patch \ |
| 31 | file://openl2tpd-initscript-fix-sysconfig.patch \ |
| 32 | file://openl2tpd-initscript-fix-warning.patch \ |
| 33 | file://openl2tpd.service \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 34 | file://openl2tpd-enable-tests.patch \ |
| 35 | file://run-ptest \ |
| 36 | file://fix_linux_4.15_compile.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 37 | file://0002-user-ipv6-structures.patch \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 38 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 39 | SRC_URI[md5sum] = "e3d08dedfb9e6a9a1e24f6766f6dadd0" |
| 40 | SRC_URI[sha256sum] = "1c97704d4b963a87fbc0e741668d4530933991515ae9ab0dffd11b5444f4860f" |
| 41 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 42 | inherit autotools-brokensep pkgconfig systemd ptest |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 43 | |
| 44 | SYSTEMD_SERVICE_${PN} = "openl2tpd.service" |
| 45 | SYSTEMD_AUTO_ENABLE = "disable" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 46 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 47 | DEPENDS += "libtirpc" |
| 48 | CPPFLAGS += "-I${STAGING_INCDIR}/tirpc" |
| 49 | CFLAGS += "-I${STAGING_INCDIR}/tirpc" |
| 50 | LDFLAGS += "-ltirpc" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 51 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 52 | PARALLEL_MAKE = "" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 53 | EXTRA_OEMAKE = 'CFLAGS="${CFLAGS} -Wno-unused-but-set-variable" CPPFLAGS="${CPPFLAGS}" OPT_CFLAGS="${CFLAGS}"' |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 54 | |
| 55 | do_compile_prepend() { |
| 56 | sed -i -e "s:SYS_LIBDIR=.*:SYS_LIBDIR=${libdir}:g" \ |
| 57 | -e 's:$(CROSS_COMPILE)as:${AS}:g' \ |
| 58 | -e 's:$(CROSS_COMPILE)ld:${LD}:g' \ |
| 59 | -e 's:$(CROSS_COMPILE)gcc:${CC}:g' \ |
| 60 | -e 's:$(CROSS_COMPILE)ar:${AR}:g' \ |
| 61 | -e 's:$(CROSS_COMPILE)nm:${NM}:g' \ |
| 62 | -e 's:$(CROSS_COMPILE)strip:${STRIP}:g' \ |
| 63 | -e 's:$(CROSS_COMPILE)install:install:g' \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 64 | -e 's:CPPFLAGS-y:CPPFLAGS:g' \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 65 | ${S}/Makefile |
| 66 | } |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 67 | |
| 68 | do_install_append () { |
| 69 | install -d ${D}${sysconfdir}/init.d |
| 70 | install -d ${D}${sysconfdir}/default |
| 71 | install -m 0755 ${S}/etc/rc.d/init.d/openl2tpd ${D}${sysconfdir}/init.d/openl2tpd |
| 72 | install -m 0755 ${S}/etc/sysconfig/openl2tpd ${D}${sysconfdir}/default/openl2tpd |
| 73 | |
| 74 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 75 | install -D -m 0644 ${WORKDIR}/openl2tpd.service ${D}${systemd_system_unitdir}/openl2tpd.service |
| 76 | sed -i -e 's,@STATEDIR@,${localstatedir},g' \ |
| 77 | -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
| 78 | -e 's,@SBINDIR@,${sbindir},g' \ |
| 79 | -e 's,@BINDIR@,${bindir},g' \ |
| 80 | -e 's,@BASE_SBINDIR@,${base_sbindir},g' \ |
| 81 | -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 82 | ${D}${systemd_system_unitdir}/openl2tpd.service |
| 83 | fi |
| 84 | } |
| 85 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 86 | do_install_ptest () { |
| 87 | for i in all.tcl configfile.test peer_profile.test ppp_profile.test \ |
| 88 | session_profile.test session.test system.test test_procs.tcl \ |
| 89 | thirdparty_lns.test tunnel_profile.test tunnel.test; do |
| 90 | install -m 0755 ${S}/test/$i ${D}${PTEST_PATH} |
| 91 | done |
| 92 | } |
| 93 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 94 | RDEPENDS_${PN} = "ppp ppp-l2tp bash" |