blob: b0a1937576ff9c6284abdf32c53b2c451aa5acc8 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Guess OpenSSL include path"
2SECTION = "libs"
3LICENSE = "Artistic-1.0 | GPL-1.0+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ea914cc2718e8d53bd7744d96e66c03c"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-Guess-${PV}.tar.gz "
7
Andrew Geissler69721092021-07-23 12:57:00 -04008SRC_URI[sha256sum] = "87c1dd7f0f80fcd3d1396bce9fd9962e7791e748dc0584802f8d10cc9585e743"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009
10DEPENDS += "openssl"
11
Brad Bishop15ae2502019-06-18 21:44:24 -040012RDEPENDS_${PN} = "\
13 perl-module-config \
14 perl-module-exporter \
15 perl-module-extutils-mm \
16 perl-module-extutils-mm-unix \
17 perl-module-file-spec \
18 perl-module-symbol \
19 perl-module-strict \
20 perl-module-warnings \
21"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022
23EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
24
25S = "${WORKDIR}/Crypt-OpenSSL-Guess-${PV}"
26
Brad Bishop15ae2502019-06-18 21:44:24 -040027inherit cpan ptest-perl
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028
29BBCLASSEXTEND = "native"
Brad Bishop15ae2502019-06-18 21:44:24 -040030
31# for backwards compatibility
32PROVIDES_${PN} += "libcrypt-openssl-guess"
33
34RDEPENDS_${PN}-ptest += "\
35 perl-module-test-more \
36"