Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "Command line utility to extend hash of arbitrary data into a TPMs PCR." |
| 2 | HOMEPAGE = "https://github.com/flihp/pcr-extend" |
| 3 | SECTION = "security/tpm" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | DEPENDS = "libtspi" |
| 8 | |
| 9 | PV = "0.1+git${SRCPV}" |
| 10 | SRCREV = "c02ad8f628b3d99f6d4c087b402fe31a40ee6316" |
| 11 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | SRC_URI = "git://github.com/flihp/pcr-extend.git \ |
| 13 | file://fix_openssl11_build.patch " |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 14 | |
| 15 | inherit autotools |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | do_compile() { |
| 20 | oe_runmake -C ${S}/src |
| 21 | } |
| 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}${bindir} |
| 25 | oe_runmake -C ${S}/src DESTDIR="${D}" install |
| 26 | } |