Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Target Communication Framework for the Eclipse IDE" |
| 2 | HOMEPAGE = "http://wiki.eclipse.org/TCF" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 3 | DESCRIPTION = "TCF is a vendor-neutral, lightweight, extensible network protocol mainly for communicating with embedded systems (targets)." |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 4 | BUGTRACKER = "https://bugs.eclipse.org/bugs/" |
| 5 | |
| 6 | LICENSE = "EPL-1.0 | EDL-1.0" |
| 7 | LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679" |
| 8 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | SRCREV = "a022ef2f1acfd9209a1bf792dda14ae4b0d1b60f" |
| 10 | PV = "1.7.0+git${SRCPV}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 12 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | file://fix_ranlib.patch \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 15 | file://ldflags.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | file://tcf-agent.init \ |
| 17 | file://tcf-agent.service \ |
| 18 | " |
| 19 | |
| 20 | DEPENDS = "util-linux openssl" |
| 21 | RDEPENDS_${PN} = "bash" |
| 22 | |
| 23 | S = "${WORKDIR}/git/agent" |
| 24 | |
| 25 | inherit update-rc.d systemd |
| 26 | |
| 27 | SYSTEMD_SERVICE_${PN} = "tcf-agent.service" |
| 28 | |
| 29 | INITSCRIPT_NAME = "tcf-agent" |
| 30 | INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ." |
| 31 | |
| 32 | # mangling needed for make |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686, | sed s,aarch64.*,a64, | sed s,armeb,arm,`" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 34 | MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`" |
| 35 | |
| 36 | EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'" |
| 37 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 38 | LCL_STOP_SERVICES = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 39 | -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 40 | -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0" |
| 41 | |
| 42 | |
| 43 | # These features don't compile for several cases. |
| 44 | # |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 45 | CFLAGS_append_arc = " ${LCL_STOP_SERVICES}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 46 | CFLAGS_append_mips = " ${LCL_STOP_SERVICES}" |
| 47 | CFLAGS_append_mips64 = " ${LCL_STOP_SERVICES}" |
| 48 | CFLAGS_append_libc-musl = " ${LCL_STOP_SERVICES}" |
| 49 | CFLAGS_append_powerpc64 = " ${LCL_STOP_SERVICES}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 50 | CFLAGS_append_powerpc64le = " ${LCL_STOP_SERVICES}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 51 | CFLAGS_append_riscv64 = " ${LCL_STOP_SERVICES}" |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 52 | CFLAGS_append_riscv32 = " ${LCL_STOP_SERVICES}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 53 | |
| 54 | do_install() { |
| 55 | oe_runmake install INSTALLROOT=${D} |
| 56 | install -d ${D}${sysconfdir}/init.d/ |
| 57 | install -m 0755 ${WORKDIR}/tcf-agent.init ${D}${sysconfdir}/init.d/tcf-agent |
| 58 | install -d ${D}${systemd_unitdir}/system |
| 59 | install -m 0644 ${WORKDIR}/tcf-agent.service ${D}${systemd_unitdir}/system |
| 60 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tcf-agent.service |
| 61 | } |
| 62 | |