Andrew Geissler | a9ff2b3 | 2020-10-16 10:11:54 -0500 | [diff] [blame] | 1 | # Add MicroBlaze Patches (only when using MicroBlaze) |
| 2 | FILESEXTRAPATHS_append_microblaze := ":${THISDIR}/gcc-10" |
| 3 | |
| 4 | SRC_URI_append_microblaze = " \ |
| 5 | file://0001-LOCAL-Testsuite-builtins-tests-require-fpic.patch \ |
| 6 | file://0002-LOCAL-Quick-fail-g-.dg-opt-memcpy1.C.patch \ |
Andrew Geissler | 10fa149 | 2020-12-11 16:25:29 -0600 | [diff] [blame] | 7 | file://0003-LOCAL-For-dejagnu-static-testing-on-qemu-suppress-wa.patch \ |
| 8 | file://0004-Patch-testsuite-Add-MicroBlaze-to-target-supports-fo.patch \ |
| 9 | file://0005-Patch-testsuite-Update-MicroBlaze-strings-test.patch \ |
| 10 | file://0006-Patch-testsuite-Allow-MicroBlaze-.weakext-pattern-in.patch \ |
| 11 | file://0007-Patch-testsuite-Add-MicroBlaze-to-check_profiling_av.patch \ |
| 12 | file://0008-Patch-microblaze-Fix-atomic-side-effects.patch \ |
| 13 | file://0009-Patch-microblaze-Fix-atomic-boolean-return-value.patch \ |
| 14 | file://0010-Patch-microblaze-Fix-the-Microblaze-crash-with-msmal.patch \ |
| 15 | file://0011-Patch-microblaze-Added-ashrsi3_with_size_opt.patch \ |
| 16 | file://0012-Patch-microblaze-Use-bralid-for-profiler-calls.patch \ |
| 17 | file://0013-Patch-microblaze-Removed-moddi3-routinue.patch \ |
| 18 | file://0014-Patch-microblaze-Add-INIT_PRIORITY-support.patch \ |
| 19 | file://0015-Patch-microblaze-Add-optimized-lshrsi3.patch \ |
| 20 | file://0016-Patch-microblaze-Add-cbranchsi4_reg.patch \ |
| 21 | file://0017-Patch-microblaze-Inline-Expansion-of-fsqrt-builtin.patch \ |
| 22 | file://0018-PATCH-microblaze.md-Improve-adddi3-and-subdi3-insn-d.patch \ |
| 23 | file://0019-Patch-microblaze-Update-ashlsi3-movsf-patterns.patch \ |
| 24 | file://0020-Patch-microblaze-8-stage-pipeline-for-microblaze.patch \ |
| 25 | file://0021-Patch-microblaze-Correct-the-const-high-double-immed.patch \ |
| 26 | file://0022-Fix-microblaze-Fix-internal-compiler-error-with-msma.patch \ |
| 27 | file://0023-patch-microblaze-Fix-the-calculation-of-high-word-in.patch \ |
| 28 | file://0024-Patch-microblaze-Add-new-bit-field-instructions.patch \ |
| 29 | file://0025-Patch-microblaze-Fix-bug-in-MB-version-calculation.patch \ |
| 30 | file://0026-Fixing-the-issue-with-the-builtin_alloc.patch \ |
| 31 | file://0027-Patch-Microblaze-update-in-constraints-for-bitfield-.patch \ |
| 32 | file://0028-Patch-Microblaze-Removed-fsqrt-generation-for-double.patch \ |
| 33 | file://0029-Patch-MicroBlaze-Intial-commit-of-64-bit-Microblaze.patch \ |
| 34 | file://0030-Intial-commit-for-64bit-MB-sources.patch \ |
| 35 | file://0031-re-arrangement-of-the-compare-branches.patch \ |
| 36 | file://0032-Patch-Microblaze-previous-commit-broke-the-handling-.patch \ |
| 37 | file://0033-Patch-Microblaze-Support-of-multilibs-with-m64.patch \ |
| 38 | file://0034-Fixed-issues-like.patch \ |
| 39 | file://0035-Fixed-below-issues.patch \ |
| 40 | file://0036-Added-double-arith-instructions.patch \ |
| 41 | file://0037-Fixed-the-issue-in-the-delay-slot-with-swap-instruct.patch \ |
| 42 | file://0038-Fixed-the-load-store-issue-with-the-32bit-arith-libr.patch \ |
| 43 | file://0039-extending-the-Dwarf-support-to-64bit-Microblaze.patch \ |
| 44 | file://0040-fixing-the-typo-errors-in-umodsi3-file.patch \ |
| 45 | file://0041-fixing-the-32bit-LTO-related-issue9-1014024.patch \ |
| 46 | file://0042-Fixed-the-missing-stack-adjustment-in-prologue-of-mo.patch \ |
| 47 | file://0043-Patch-Microblaze-corrected-SPN-for-dlong-instruction.patch \ |
| 48 | file://0044-fixing-the-long-long-long-mingw-toolchain-issue.patch \ |
| 49 | file://0045-Fix-the-MB-64-bug-of-handling-QI-objects.patch \ |
| 50 | file://0046-Patch-Microblaze-We-will-check-the-possibility-of-pe.patch \ |
| 51 | file://0047-Patch-MicroBlaze-fixed-typos-in-mul-div-and-mod-asse.patch \ |
| 52 | file://0048-Author-Nagaraju-nmekala-xilinx.com.patch \ |
| 53 | file://0049-Added-new-MB-64-single-register-arithmetic-instructi.patch \ |
| 54 | file://0050-Patch-MicroBlaze-Added-support-for-64-bit-Immediate-.patch \ |
| 55 | file://0051-Patch-microblaze-Fix-Compiler-crash-with-freg-struct.patch \ |
| 56 | file://0052-Patch-microblaze-Add-TARGET_OPTION_OPTIMIZATION-and-.patch \ |
| 57 | file://0053-Patch-microblaze-Reducing-Stack-space-for-arguments.patch \ |
| 58 | file://microblaze-mulitlib-hack.patch \ |
Andrew Geissler | a9ff2b3 | 2020-10-16 10:11:54 -0500 | [diff] [blame] | 59 | " |