blob: eceed9c9dd45088ddb37b4a7f50a507514d2b134 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "jQuery is a fast, small, and feature-rich JavaScript library"
2HOMEPAGE = "https://jquery.com/"
3DESCRIPTION = "${SUMMARY}"
4LICENSE = "MIT"
5SECTION = "devel"
Patrick Williams2a254922023-08-11 09:48:11 -05006LIC_FILES_CHKSUM = "file://${S}/${BP}.js;beginline=5;endline=7;md5=9c7c6e9ab275fc1e0d99cb7180ecd14c"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8# unpack items to ${S} so the archiver can see them
9#
10SRC_URI = "\
11 https://code.jquery.com/${BP}.js;name=js;subdir=${BP} \
12 https://code.jquery.com/${BP}.min.js;name=min;subdir=${BP} \
13 https://code.jquery.com/${BP}.min.map;name=map;subdir=${BP} \
14 "
15
Patrick Williams2a254922023-08-11 09:48:11 -050016SRC_URI[js.sha256sum] = "265a924c42de4784cba8fd0e1bd77133bc833ea5f5a31fc77e08922c18fcfa43"
17SRC_URI[min.sha256sum] = "d8f9afbf492e4c139e9d2bcb9ba6ef7c14921eb509fb703bc7a3f911b774eff8"
18SRC_URI[map.sha256sum] = "cae47e834ee977975a48c851b165cc52ea916cc968ba7d280b1293f573cd1a48"
Andrew Geissler517393d2023-01-13 08:55:19 -060019
20UPSTREAM_CHECK_REGEX = "jquery-(?P<pver>\d+(\.\d+)+)\.js"
21
22# https://github.com/jquery/jquery/issues/3927
Andrew Geissler8f840682023-07-21 09:09:43 -050023CVE_STATUS[CVE-2007-2379] = "upstream-wontfix: There are ways jquery can expose security issues but any issues \
24are in the apps exposing them and there is little we can directly do."
Andrew Geissler517393d2023-01-13 08:55:19 -060025
26inherit allarch
27
28do_install() {
29 install -d ${D}${datadir}/javascript/${BPN}/
30 install -m 644 ${S}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js
31 install -m 644 ${S}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js
32 install -m 644 ${S}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map
33}
34
35PACKAGES = "${PN}"
36FILES:${PN} = "${datadir}"
37
38BBCLASSEXTEND += "native nativesdk"