Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "lib-curses provides an interface between Perl programs and \ |
| 2 | the curses library." |
| 3 | |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a3422d82af8af09" |
| 8 | |
| 9 | DEPENDS += "perl ncurses " |
| 10 | |
| 11 | SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz" |
| 12 | |
| 13 | SRC_URI[md5sum] = "389c70ee5530b887f8e5dc1303cb5294" |
| 14 | SRC_URI[sha256sum] = "a414795ba031c5918c70279fe534fee594a96ec4b0c78f44ce453090796add64" |
| 15 | |
| 16 | S = "${WORKDIR}/Curses-${PV}" |
| 17 | |
| 18 | EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR}" |
| 19 | |
| 20 | inherit cpan |
| 21 | |
| 22 | do_compile() { |
| 23 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 24 | cpan_do_compile |
| 25 | } |
| 26 | |