Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Library and tool for installing Python wheels" |
| 2 | DESCRIPTION = "A low-level library for installing a Python package from a wheel distribution." |
| 3 | HOMEPAGE = "https://installer.readthedocs.io/" |
| 4 | BUGTRACKER = "https://github.com/pypa/installer/issues" |
| 5 | |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5038641aec7a77451e31da828ebfae00" |
| 8 | |
| 9 | SRC_URI += "file://interpreter.patch" |
| 10 | |
| 11 | SRC_URI[sha256sum] = "f970995ec2bb815e2fdaf7977b26b2091e1e386f0f42eafd5ac811953dc5d445" |
| 12 | |
| 13 | inherit pypi python_flit_core |
| 14 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 15 | # Bootstrap the native build |
| 16 | DEPENDS:remove:class-native = "python3-picobuild-native python3-installer-native" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 17 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 18 | INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode" |
| 19 | |
| 20 | do_compile:class-native () { |
| 21 | python_flit_core_do_manual_build |
| 22 | } |
| 23 | |
| 24 | do_install:prepend:class-native() { |
| 25 | export PYTHONPATH="${S}/src" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 26 | } |
| 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |