Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Framework for layout and rendering of internationalized text" |
| 2 | DESCRIPTION = "Pango is a library for laying out and rendering of text, \ |
| 3 | with an emphasis on internationalization. Pango can be used anywhere \ |
| 4 | that text layout is needed, though most of the work on Pango so far has \ |
| 5 | been done in the context of the GTK+ widget toolkit. Pango forms the \ |
| 6 | core of text and font handling for GTK+-2.x." |
| 7 | HOMEPAGE = "http://www.pango.org/" |
| 8 | BUGTRACKER = "http://bugzilla.gnome.org" |
| 9 | SECTION = "libs" |
| 10 | LICENSE = "LGPLv2.0+" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" |
| 13 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | GNOMEBASEBUILDCLASS = "meson" |
| 15 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection |
| 17 | |
Brad Bishop | c68388fc | 2019-08-26 01:33:31 -0400 | [diff] [blame] | 18 | SRC_URI += "file://run-ptest" |
| 19 | SRC_URI[archive.md5sum] = "b6bf689e3ce4f46b0fd887b64c850ea1" |
| 20 | SRC_URI[archive.sha256sum] = "8527dfcbeedb4390149b6f94620c0fa64e26046ab85042c2a7556438847d7fc1" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | |
| 22 | DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi" |
| 23 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 24 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \ |
| 25 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 27 | PACKAGECONFIG[x11] = ",,virtual/libx11 libxft" |
| 28 | PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false" |
| 29 | |
| 30 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 31 | GIR_MESON_OPTION = 'introspection' |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 32 | |
| 33 | LEAD_SONAME = "libpango-1.0*" |
| 34 | LIBV = "1.8.0" |
| 35 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}" |
| 37 | FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la" |
| 38 | |
Brad Bishop | c68388fc | 2019-08-26 01:33:31 -0400 | [diff] [blame] | 39 | RDEPENDS_${PN}-ptest += "cantarell-fonts" |
| 40 | RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 41 | |
| 42 | RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \ |
| 43 | pango-module-basic-fc pango-module-arabic-lang" |
| 44 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 45 | BBCLASSEXTEND = "native nativesdk" |