blob: c9c4a6c27a5441bd723fdd7b82c40981f17ef42c [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A liberally licensed VNC server library"
2DESCRIPTION = "This is a liberally licensed VNC server library that's intended to be fast and neat."
3HOMEPAGE = "https://github.com/any1/neatvnc"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94fc374e7174f41e3afe0f027ee59ff7"
6
Patrick Williams03514f12024-04-05 07:04:11 -05007SRC_URI = "git://github.com/any1/neatvnc;branch=master;protocol=https"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
Patrick Williams03514f12024-04-05 07:04:11 -05009SRCREV = "46432ce8cade0b54a38d4bb42eb07f96c8ff49fd"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060010
11S = "${WORKDIR}/git"
12
13DEPENDS = "libdrm pixman aml zlib"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[tls] = "-Dtls=enabled,-Dtls=disabled,gnutls"
17PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,libjpeg-turbo"
18PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false,libpng"
19PACKAGECONFIG[benchmarks] = "-Dbenchmarks=true,-Dbenchmarks=false,libpng"
20
21PACKAGE_BEFORE_PN += "${PN}-examples"
22ALLOW_EMPTY:${PN}-examples = "1"
23FILES:${PN}-examples = "${bindir}"
24
25NEATVNC_EXAMPLES = "draw png-server"
26
27inherit meson pkgconfig
28
29do_install:append () {
30 if ${@bb.utils.contains('PACKAGECONFIG', 'examples', 'true', 'false', d)}; then
31 install -d ${D}${bindir}
32 for bin in ${NEATVNC_EXAMPLES}; do
33 install -m 0755 ${B}/examples/$bin ${D}${bindir}
34 done
35 fi
36}
37
38BBCLASSEXTEND = "native"