Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "A liberally licensed VNC server library" |
| 2 | DESCRIPTION = "This is a liberally licensed VNC server library that's intended to be fast and neat." |
| 3 | HOMEPAGE = "https://github.com/any1/neatvnc" |
| 4 | LICENSE = "ISC" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94fc374e7174f41e3afe0f027ee59ff7" |
| 6 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 7 | SRC_URI = "git://github.com/any1/neatvnc;branch=master;protocol=https" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 8 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 9 | SRCREV = "46432ce8cade0b54a38d4bb42eb07f96c8ff49fd" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | DEPENDS = "libdrm pixman aml zlib" |
| 14 | |
| 15 | PACKAGECONFIG ??= "" |
| 16 | PACKAGECONFIG[tls] = "-Dtls=enabled,-Dtls=disabled,gnutls" |
| 17 | PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,libjpeg-turbo" |
| 18 | PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false,libpng" |
| 19 | PACKAGECONFIG[benchmarks] = "-Dbenchmarks=true,-Dbenchmarks=false,libpng" |
| 20 | |
| 21 | PACKAGE_BEFORE_PN += "${PN}-examples" |
| 22 | ALLOW_EMPTY:${PN}-examples = "1" |
| 23 | FILES:${PN}-examples = "${bindir}" |
| 24 | |
| 25 | NEATVNC_EXAMPLES = "draw png-server" |
| 26 | |
| 27 | inherit meson pkgconfig |
| 28 | |
| 29 | do_install:append () { |
| 30 | if ${@bb.utils.contains('PACKAGECONFIG', 'examples', 'true', 'false', d)}; then |
| 31 | install -d ${D}${bindir} |
| 32 | for bin in ${NEATVNC_EXAMPLES}; do |
| 33 | install -m 0755 ${B}/examples/$bin ${D}${bindir} |
| 34 | done |
| 35 | fi |
| 36 | } |
| 37 | |
| 38 | BBCLASSEXTEND = "native" |