blob: e7f4aacc2e0f674dd080fb88f221cb2a2197e536 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "GNU Midnight Commander is a visual file manager, licensed under GNU General Public License and therefore qualifies as Free Software. It's a feature rich full-screen text mode application that allows you to copy, move and delete files and whole directory trees, search for files and run commands in the subshell. Internal viewer and editor are included."
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LICENSE = "GPL-3.0-only"
Brad Bishop19323692019-04-05 15:28:33 -04005LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
6SECTION = "console/utils"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05007DEPENDS = "ncurses glib-2.0 util-linux file-replacement-native"
Patrick Williams213cb262021-08-07 19:21:33 -05008RDEPENDS:${PN} = "ncurses-terminfo-base"
9RRECOMMENDS:${PN} = "ncurses-terminfo"
Brad Bishop19323692019-04-05 15:28:33 -040010
11SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
12 file://0001-mc-replace-perl-w-with-use-warnings.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050013 file://nomandate.patch \
Brad Bishop19323692019-04-05 15:28:33 -040014 "
Patrick Williams864cc432023-02-09 14:54:44 -060015SRC_URI[sha256sum] = "ba6b2d8752806ac23fe045c1b081eb66dcefa6159205c79f86c005dcaf9941c1"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050016
Brad Bishop19323692019-04-05 15:28:33 -040017inherit autotools gettext pkgconfig
18
19#
20# Both Samba (smb) and sftp require package delivered from meta-openembedded
21#
22PACKAGECONFIG ??= ""
Brad Bishop19323692019-04-05 15:28:33 -040023PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
24
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000025# enable NCURSES_WIDECHAR=1 only if ENABLE_WIDEC has not been explicitly disabled (e.g. by the distro config).
26# When compiling against the ncurses library, NCURSES_WIDECHAR needs to explicitly set to 0 in this case.
27CFLAGS:append:libc-musl = "${@' -DNCURSES_WIDECHAR=1' if bb.utils.to_boolean((d.getVar('ENABLE_WIDEC') or 'True')) else ' -DNCURSES_WIDECHAR=0'}"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050028EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --disable-configure-args"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050029EXTRANATIVEPATH += "file-native"
Brad Bishop19323692019-04-05 15:28:33 -040030
31CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060032CACHED_CONFIGUREVARS += "ac_cv_path_PERL_FOR_BUILD='/usr/bin/env perl'"
Brad Bishop1d80a2e2019-11-15 16:35:03 -050033CACHED_CONFIGUREVARS += "ac_cv_path_PYTHON='/usr/bin/env python'"
34CACHED_CONFIGUREVARS += "ac_cv_path_GREP='/usr/bin/env grep'"
Andrew Geissler82c905d2020-04-13 13:39:40 -050035CACHED_CONFIGUREVARS += "mc_cv_have_zipinfo=yes"
Brad Bishop19323692019-04-05 15:28:33 -040036
Patrick Williams213cb262021-08-07 19:21:33 -050037do_install:append () {
Brad Bishop19323692019-04-05 15:28:33 -040038 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
39
40 rm ${D}${libexecdir}/mc/extfs.d/s3+ ${D}${libexecdir}/mc/extfs.d/uc1541
41}
42
43PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
44
Patrick Williams213cb262021-08-07 19:21:33 -050045SUMMARY:${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
46FILES:${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
Brad Bishop19323692019-04-05 15:28:33 -040047 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
48 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
49 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
50 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
51 ${libexecdir}/mc/extfs.d/uzip"
Patrick Williams213cb262021-08-07 19:21:33 -050052RDEPENDS:${BPN}-helpers-perl = "perl"
Brad Bishop19323692019-04-05 15:28:33 -040053
Patrick Williams213cb262021-08-07 19:21:33 -050054SUMMARY:${BPN}-helpers = "Midnight Commander shell helper scripts"
55FILES:${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
Brad Bishop19323692019-04-05 15:28:33 -040056
Patrick Williams213cb262021-08-07 19:21:33 -050057SUMMARY:${BPN}-fish = "Midnight Commander Fish scripts"
58FILES:${BPN}-fish = "${libexecdir}/mc/fish"