Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 3 | inherit_defer native |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 4 | |
| 5 | DEPENDS = "glib-2.0-native" |
| 6 | |
| 7 | # build native helpers |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 8 | do_configure[noexec] = "1" |
| 9 | |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 10 | do_compile() { |
| 11 | cd ${S}/src/camel |
| 12 | sed -i 's:#include "evolution-data-server-config.h"::g' camel-gen-tables.c |
| 13 | ${CC} -o ${B}/camel-gen-tables camel-gen-tables.c ${CFLAGS} ${LDFLAGS} |
| 14 | |
| 15 | LDFLAGS_glib=`pkg-config glib-2.0 --libs` |
| 16 | CFLAGS_glib=`pkg-config glib-2.0 --cflags` |
| 17 | cd ${S}/src/addressbook/libebook-contacts |
| 18 | sed -i 's:#include "evolution-data-server-config.h"::g' gen-western-table.c |
| 19 | ${CC} -o ${B}/gen-western-table gen-western-table.c ${CFLAGS} ${CFLAGS_glib} ${LDFLAGS} ${LDFLAGS_glib} |
| 20 | } |
| 21 | |
| 22 | do_install() { |
| 23 | install -d ${D}${bindir} |
| 24 | install -m 755 ${B}/* ${D}${bindir} |
| 25 | } |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 26 | |