Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 1 | SUMMARY = "Installation scripts and binaries for the Raspberry Pi 4 EEPROM" |
| 2 | DESCRIPTION = "This repository contains the rpi4 bootloader and scripts \ |
| 3 | for updating it in the spi eeprom" |
| 4 | LICENSE = "BSD-3-Clause & Broadcom-RPi" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f546ed4f47e9d4c1fe954ecc9d3ef4f3" |
| 6 | |
| 7 | SRC_URI = " \ |
| 8 | git://github.com/raspberrypi/rpi-eeprom.git;protocol=https;branch=master \ |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 9 | " |
| 10 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 11 | SRCREV = "36e58db5c2a2656e553441f4f48f32227809105d" |
| 12 | PV = "v.2024.02.16-2712" |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | RDEPENDS:${PN} += " \ |
| 17 | coreutils \ |
| 18 | python3 \ |
| 19 | python3-pycryptodomex \ |
| 20 | openssl \ |
| 21 | xxd \ |
| 22 | pciutils \ |
| 23 | " |
| 24 | |
| 25 | inherit python3native |
| 26 | |
| 27 | do_install() { |
| 28 | install -d ${D}${bindir} |
| 29 | |
| 30 | # install executables |
| 31 | install -m 0755 ${S}/tools/vl805 ${D}${bindir} |
| 32 | install -m 0755 ${S}/rpi-eeprom-update ${D}${bindir} |
| 33 | install -m 0755 ${S}/rpi-eeprom-config ${D}${bindir} |
| 34 | install -m 0755 ${S}/rpi-eeprom-digest ${D}${bindir} |
| 35 | |
| 36 | # copy firmware files |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 37 | install -d ${D}${base_libdir}/firmware/raspberrypi/bootloader-2711/default |
| 38 | install -d ${D}${base_libdir}/firmware/raspberrypi/bootloader-2711/latest |
| 39 | install -d ${D}${base_libdir}/firmware/raspberrypi/bootloader-2712/default |
| 40 | install -d ${D}${base_libdir}/firmware/raspberrypi/bootloader-2712/latest |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 41 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 42 | install -m 644 ${S}/firmware-2711/default/* ${D}${base_libdir}/firmware/raspberrypi/bootloader-2711/default |
| 43 | install -m 644 ${S}/firmware-2711/latest/* ${D}${base_libdir}/firmware/raspberrypi/bootloader-2711/latest |
| 44 | install -m 644 ${S}/firmware-2712/default/* ${D}${base_libdir}/firmware/raspberrypi/bootloader-2712/default |
| 45 | install -m 644 ${S}/firmware-2712/latest/* ${D}${base_libdir}/firmware/raspberrypi/bootloader-2712/latest |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 46 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 47 | ln -s default ${D}${base_libdir}/firmware/raspberrypi/bootloader-2711/critical |
| 48 | ln -s latest ${D}${base_libdir}/firmware/raspberrypi/bootloader-2711/stable |
| 49 | ln -s latest ${D}${base_libdir}/firmware/raspberrypi/bootloader-2711/beta |
| 50 | ln -s default ${D}${base_libdir}/firmware/raspberrypi/bootloader-2712/critical |
| 51 | ln -s latest ${D}${base_libdir}/firmware/raspberrypi/bootloader-2712/stable |
| 52 | ln -s latest ${D}${base_libdir}/firmware/raspberrypi/bootloader-2712/beta |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 53 | |
| 54 | # copy default config |
| 55 | install -d ${D}${sysconfdir}/default |
| 56 | install -D ${S}/rpi-eeprom-update-default ${D}${sysconfdir}/default/rpi-eeprom-update |
| 57 | } |
| 58 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 59 | FILES:${PN} += "${base_libdir}/firmware/raspberrypi/bootloader-*" |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 60 | |
| 61 | INHIBIT_PACKAGE_STRIP = "1" |
| 62 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
| 63 | |
| 64 | # vl805 tool sources are not available (yet), as it comes as a precompiled |
| 65 | # binary only. It has ARM architecture whereas target machine is Aarch64. We |
| 66 | # need to disable arch check for it otherwise it cannot packed. |
| 67 | QAPATHTEST[arch] = "" |
| 68 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 69 | COMPATIBLE_MACHINE = "raspberrypi4|raspberrypi4-64|raspberrypi5" |