Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "VA-API support to GStreamer" |
| 2 | DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \ |
| 3 | based plugins for GStreamer and helper libraries: `vaapidecode', \ |
| 4 | `vaapiconvert', and `vaapisink'." |
| 5 | |
| 6 | REALPN = "gstreamer-vaapi" |
| 7 | |
| 8 | LICENSE = "LGPLv2.1+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
| 10 | |
| 11 | SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz \ |
| 12 | file://0001-vaapsink-downgrade-to-marginal.patch \ |
| 13 | " |
| 14 | |
| 15 | SRC_URI[md5sum] = "13f7cb6a64bde24e67f563377487dcce" |
| 16 | SRC_URI[sha256sum] = "191de7b0ab64a85dd0875c990721e7be95518f60e2a9106beca162004ed7c601" |
| 17 | |
| 18 | S = "${WORKDIR}/${REALPN}-${PV}" |
| 19 | DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" |
| 20 | |
| 21 | inherit meson pkgconfig gtk-doc features_check upstream-version-is-even |
| 22 | |
| 23 | REQUIRED_DISTRO_FEATURES ?= "opengl" |
| 24 | |
| 25 | EXTRA_OEMESON += " \ |
| 26 | -Dexamples=disabled \ |
| 27 | " |
| 28 | |
| 29 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 30 | GTKDOC_MESON_ENABLE_FLAG = "enabled" |
| 31 | GTKDOC_MESON_DISABLE_FLAG = "disabled" |
| 32 | |
| 33 | PACKAGES =+ "${PN}-tests" |
| 34 | |
| 35 | # OpenGL packageconfig factored out to make it easy for distros |
| 36 | # and BSP layers to pick either glx, egl, or no GL. By default, |
| 37 | # try detecting X11 first, and if found (with OpenGL), use GLX, |
| 38 | # otherwise try to check if EGL can be used. |
| 39 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \ |
| 40 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \ |
| 41 | '', d), d)}" |
| 42 | |
| 43 | PACKAGECONFIG ??= "drm encoders \ |
| 44 | ${PACKAGECONFIG_GL} \ |
| 45 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 46 | |
| 47 | PACKAGECONFIG[drm] = "-Dwith_drm=yes,-Dwith_drm=no,udev libdrm" |
| 48 | PACKAGECONFIG[egl] = "-Dwith_egl=yes,-Dwith_egl=no,virtual/egl" |
| 49 | PACKAGECONFIG[encoders] = "-Dwith_encoders=yes,-Dwith_encoders=no" |
| 50 | PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/libgl" |
| 51 | PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland wayland-protocols" |
| 52 | PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxrandr libxrender" |
| 53 | |
| 54 | FILES_${PN} += "${libdir}/gstreamer-*/*.so" |
| 55 | FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug" |
| 56 | FILES_${PN}-dev += "${libdir}/gstreamer-*/*.a" |
| 57 | FILES_${PN}-tests = "${bindir}/*" |