Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 1 | # SPDX-FileCopyrightText: Huawei Inc. |
| 2 | # SPDX-License-Identifier: MIT |
| 3 | |
| 4 | SRC_URI = "gitsm://git.ostc-eu.org/rzr/dialog-lvgl;destsuffix=${S};protocol=https;nobranch=1" |
| 5 | SRCREV = "5d2121457a6988c97cacb0790594440693fc3d29" |
| 6 | |
| 7 | LICENSE = "MIT" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8ce0a84e5276f01364119c873b712c4f" |
| 9 | AUTHOR = "Philippe Coval <philippe.coval.ext@huawei.com>" |
| 10 | |
| 11 | DEPENDS += "lvgl" |
| 12 | DEPENDS += "lv-drivers" |
| 13 | |
| 14 | SUMMARY = "Basic UI utility to be used in scripts" |
| 15 | DESCRIPTION = "Inspired by ncurses' dialog, implemented using LVGL" |
| 16 | HOMEPAGE = "https://git.ostc-eu.org/rzr/dialog-lvgl/-/wikis/" |
| 17 | |
| 18 | REQUIRED_DISTRO_FEATURES = "wayland" |
| 19 | |
| 20 | inherit pkgconfig |
| 21 | inherit features_check |
| 22 | |
| 23 | EXTRA_OEMAKE += "sysroot=${RECIPE_SYSROOT}" |
| 24 | EXTRA_OEMAKE += "DESTDIR=${D}" |
| 25 | EXTRA_OEMAKE += "lvgl_driver=wayland" |
| 26 | |
| 27 | do_install() { |
| 28 | oe_runmake install |
| 29 | } |