Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "display dialog boxes from shell scripts" |
| 2 | DESCRIPTION = "Dialog lets you to present a variety of questions \ |
| 3 | or display messages using dialog boxes from a shell \ |
| 4 | script (or any scripting language)." |
| 5 | HOMEPAGE = "http://invisible-island.net/dialog/" |
| 6 | SECTION = "console/utils" |
| 7 | DEPENDS = "ncurses" |
| 8 | LICENSE = "LGPL-2.1" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 10 | |
| 11 | SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz \ |
| 12 | " |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 13 | SRC_URI[md5sum] = "e9d7f8b5e7b17183b0fb9297c0f57840" |
| 14 | SRC_URI[sha256sum] = "e5eb0eaaef9cae8c822887bd998e33c2c3b94ebadd37b4f6aba018c0194a2a87" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | |
| 16 | # hardcoded here for use in dialog-static recipe |
| 17 | S = "${WORKDIR}/dialog-${PV}" |
| 18 | |
| 19 | inherit autotools-brokensep pkgconfig |
| 20 | |
| 21 | EXTRA_OECONF = "--with-ncurses \ |
| 22 | --disable-rpath-hack" |
| 23 | |
| 24 | do_configure() { |
| 25 | gnu-configize --force |
| 26 | sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure |
| 27 | sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure |
| 28 | oe_runconf |
| 29 | } |