Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Linux kernel firmware files from Raspbian distribution" |
| 2 | DESCRIPTION = "Updated firmware files for RaspberryPi hardware. \ |
| 3 | RPi-Distro obtains these directly from Cypress; they are not submitted \ |
| 4 | to linux-firmware for general use." |
| 5 | HOMEPAGE = "https://github.com/RPi-Distro/firmware-nonfree" |
| 6 | SECTION = "kernel" |
| 7 | |
| 8 | # In maintained upstream linux-firmware: |
| 9 | # * brcmfmac43430-sdio falls under LICENCE.cypress |
| 10 | # * brcmfmac43455-sdio falls under LICENCE.broadcom_bcm43xx |
| 11 | # |
| 12 | # It is likely[^1] that both of these should be under LICENCE.cypress. |
| 13 | # Further, at this time the text of LICENCE.broadcom_bcm43xx is the same |
| 14 | # in linux-firmware and RPi-Distro/firmware-nonfree, but this may |
| 15 | # change. |
| 16 | # |
| 17 | # Rather than make assumptions about what's supposed to be what, we'll |
| 18 | # use the license implied by the source of these files, named to avoid |
| 19 | # conflicts with linux-firmware. |
| 20 | # |
| 21 | # [^1]: https://github.com/RPi-Distro/bluez-firmware/issues/1 |
| 22 | LICENSE = "\ |
| 23 | Firmware-broadcom_bcm43xx-rpidistro \ |
| 24 | & WHENCE \ |
| 25 | " |
| 26 | LIC_FILES_CHKSUM = "\ |
| 27 | file://LICENCE.broadcom_bcm43xx;md5=3160c14df7228891b868060e1951dfbc \ |
| 28 | file://WHENCE;md5=a9c2c217f513c20e1d16b384b3e2c12d \ |
| 29 | " |
| 30 | |
| 31 | # These are not common licenses, set NO_GENERIC_LICENSE for them |
| 32 | # so that the license files will be copied from fetched source |
| 33 | NO_GENERIC_LICENSE[Firmware-broadcom_bcm43xx-rpidistro] = "LICENCE.broadcom_bcm43xx" |
| 34 | NO_GENERIC_LICENSE[WHENCE] = "WHENCE" |
| 35 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 36 | SRC_URI = " \ |
| 37 | git://github.com/RPi-Distro/firmware-nonfree \ |
| 38 | file://0001-brcmfmac43455-sdio.txt-Follow-raspbian-change-for-bo.patch \ |
| 39 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 40 | SRCREV = "b518de45ced519e8f7a499f4778100173402ae43" |
| 41 | PV = "0.0+git${SRCPV}" |
| 42 | |
| 43 | S = "${WORKDIR}/git" |
| 44 | |
| 45 | inherit allarch |
| 46 | |
| 47 | CLEANBROKEN = "1" |
| 48 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 49 | do_unpack_append() { |
| 50 | bb.build.exec_func('do_clean_pc', d) |
| 51 | } |
| 52 | do_clean_pc() { |
| 53 | rm -rf ${S}/.pc |
| 54 | } |
| 55 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 56 | do_compile() { |
| 57 | : |
| 58 | } |
| 59 | |
| 60 | do_install() { |
| 61 | install -d ${D}${nonarch_base_libdir}/firmware/brcm |
| 62 | |
| 63 | cp ./LICENCE.broadcom_bcm43xx ${D}${nonarch_base_libdir}/firmware/LICENCE.broadcom_bcm43xx-rpidistro |
| 64 | |
| 65 | # Replace outdated linux-firmware files with updated ones from |
| 66 | # raspbian firmware-nonfree. Raspbian adds blobs and nvram |
| 67 | # definitions that are also necessary so copy those too. |
| 68 | for fw in brcmfmac43430-sdio brcmfmac43455-sdio ; do |
| 69 | install -m 0644 brcm/${fw}.* ${D}${nonarch_base_libdir}/firmware/brcm/ |
| 70 | done |
| 71 | } |
| 72 | |
| 73 | PACKAGES = "\ |
| 74 | ${PN}-broadcom-license \ |
| 75 | ${PN}-bcm43430 \ |
| 76 | ${PN}-bcm43455 \ |
| 77 | " |
| 78 | |
| 79 | LICENSE_${PN}-bcm43430 = "Firmware-broadcom_bcm43xx-rpidistro" |
| 80 | LICENSE_${PN}-bcm43455 = "Firmware-broadcom_bcm43xx-rpidistro" |
| 81 | LICENSE_${PN}-broadcom-license = "Firmware-broadcom_bcm43xx-rpidistro" |
| 82 | FILES_${PN}-broadcom-license = "${nonarch_base_libdir}/firmware/LICENCE.broadcom_bcm43xx-rpidistro" |
| 83 | FILES_${PN}-bcm43430 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43430*" |
| 84 | FILES_${PN}-bcm43455 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43455*" |
| 85 | RDEPENDS_${PN}-bcm43430 += "${PN}-broadcom-license" |
| 86 | RDEPENDS_${PN}-bcm43455 += "${PN}-broadcom-license" |
| 87 | RCONFLICTS_${PN}-bcm43430 = "\ |
| 88 | linux-firmware-bcm43430 \ |
| 89 | linux-firmware-raspbian-bcm43430 \ |
| 90 | " |
| 91 | RREPLACES_${PN}-bcm43430 = "\ |
| 92 | linux-firmware-bcm43430 \ |
| 93 | linux-firmware-raspbian-bcm43430 \ |
| 94 | " |
| 95 | RCONFLICTS_${PN}-bcm43455 = "\ |
| 96 | linux-firmware-bcm43455 \ |
| 97 | linux-firmware-raspbian-bcm43455 \ |
| 98 | " |
| 99 | RREPLACES_${PN}-bcm43455 = "\ |
| 100 | linux-firmware-bcm43455 \ |
| 101 | linux-firmware-raspbian-bcm43455 \ |
| 102 | " |
| 103 | |
| 104 | # Firmware files are generally not run on the CPU, so they can be |
| 105 | # allarch despite being architecture specific |
| 106 | INSANE_SKIP = "arch" |