blob: 5c6528e48bf71096c9506196829f3beb4934d9dc [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Linux system security checks"
2DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used."
3SECTION = "security"
4LICENSE = "BSD"
5HOMEPAGE="https://github.com/slimm609/checksec.sh"
6
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=93fddcca19f6c897871f9b5f9a035f4a"
8
Brad Bishop49e29a12019-09-01 15:21:06 -04009SRCREV = "04582bad41589ad479ca8b1f0170ed317475b5a5"
Brad Bishop19323692019-04-05 15:28:33 -040010SRC_URI = "git://github.com/slimm609/checksec.sh"
11
12S = "${WORKDIR}/git"
13
14do_install() {
15 install -d ${D}${bindir}
16 install -m 0755 ${S}/checksec ${D}${bindir}
17}
18
19RDEPENDS_${PN} = "bash openssl-bin"