Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
| 3 | SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/mesa-${PV}.tar.xz" |
| 4 | |
| 5 | SRC_URI[md5sum] = "553e525d2f20ed48fca8f1ec3176fd83" |
| 6 | SRC_URI[sha256sum] = "58592e07c350cd2e8969b73fa83048c657a39fe2f13f3b88f5e5818fe2e4676d" |
| 7 | |
| 8 | #because we cannot rely on the fact that all apps will use pkgconfig, |
| 9 | #make eglplatform.h independent of MESA_EGL_NO_X11_HEADER |
| 10 | do_install_append() { |
| 11 | if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then |
| 12 | sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h |
| 13 | fi |
| 14 | } |