Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "An abstraction layer for touchscreen panel events" |
| 2 | DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \ |
| 3 | events, as well as a filter stack for the manipulation of those events. \ |
| 4 | Tslib is generally used on embedded devices to provide a common user \ |
| 5 | space interface to touchscreen functionality." |
| 6 | HOMEPAGE = "http://tslib.berlios.de/" |
| 7 | |
| 8 | AUTHOR = "Russell King w/ plugins by Chris Larson et. al." |
| 9 | SECTION = "base" |
| 10 | LICENSE = "LGPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=f30a9716ef3762e3467a2f62bf790f0a" |
| 12 | |
| 13 | SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \ |
| 14 | file://ts.conf \ |
| 15 | file://tslib.sh \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI[md5sum] = "14771f8607b341bb4b297819d37e837d" |
| 19 | SRC_URI[sha256sum] = "fe35e5f710ea933b118f710e2ce4403ac076fe69926b570333867d4de082a51c" |
| 20 | |
| 21 | |
| 22 | inherit autotools pkgconfig |
| 23 | |
| 24 | EXTRA_OECONF = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00" |
| 25 | |
| 26 | do_install_prepend() { |
| 27 | install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf |
| 28 | } |
| 29 | |
| 30 | do_install_append() { |
| 31 | install -d ${D}${sysconfdir}/profile.d/ |
| 32 | install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/ |
| 33 | } |
| 34 | |
| 35 | # People should consider using udev's /dev/input/touchscreen0 symlink |
| 36 | # instead of detect-stylus |
| 37 | #RDEPENDS_tslib-conf_weird-machine = "detect-stylus" |
| 38 | RPROVIDES_tslib-conf = "libts-0.0-conf" |
| 39 | |
| 40 | PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate" |
| 41 | DEBIAN_NOAUTONAME_tslib-conf = "1" |
| 42 | DEBIAN_NOAUTONAME_tslib-tests = "1" |
| 43 | DEBIAN_NOAUTONAME_tslib-calibrate = "1" |
| 44 | |
| 45 | RDEPENDS_${PN} = "tslib-conf" |
| 46 | RRECOMMENDS_${PN} = "pointercal" |
| 47 | |
| 48 | FILES_${PN}-dbg += "${libdir}/ts/.debug*" |
| 49 | FILES_${PN}-dev += "${libdir}/ts/*.la" |
| 50 | FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib" |
| 51 | FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*" |
| 52 | FILES_tslib-calibrate += "${bindir}/ts_calibrate" |
| 53 | FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_test" |