Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "libgphoto2 allows you to access digital cameras" |
| 2 | SECTION = "libs" |
| 3 | LICENSE = "LGPLv2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0448d3676bc0de00406af227d341a4d1" |
| 5 | |
| 6 | DEPENDS = "libtool jpeg virtual/libusb0 libexif zlib libxml2" |
| 7 | |
| 8 | # The .fdi and .rules files were generated with: |
| 9 | # libgphoto2-2.5.8/packaging/generic$ qemu-arm -s 1048576 -r 2.6.24 -L /OE/angstrom-dev/staging/armv5te-angstrom-linux-gnueabi/ .libs/print-camera-list |
| 10 | # They are release specific, so please regen when adding new releases |
| 11 | |
| 12 | SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2;name=libgphoto2 \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | file://40-libgphoto2.rules \ |
| 14 | file://0001-configure.ac-remove-AM_PO_SUBDIRS.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[libgphoto2.md5sum] = "ae78e7a7936a6962c3a22b256bee1869" |
| 18 | SRC_URI[libgphoto2.sha256sum] = "417464f0a313fa937e8a71cdf18a371cf01e750830195cd63ae31da0d092b555" |
| 19 | |
| 20 | inherit autotools pkgconfig gettext lib_package |
| 21 | |
| 22 | EXTRA_OECONF = " --with-drivers=all udevscriptdir=${nonarch_base_libdir}/udev ac_cv_lib_ltdl_lt_dlcaller_register=yes" |
| 23 | |
| 24 | PACKAGECONFIG ??= "" |
| 25 | PACKAGECONFIG[gd] = ",--without-gdlib,gd" |
| 26 | PACKAGECONFIG[serial] = "--enable-serial,--disable-serial,lockdev" |
| 27 | |
| 28 | do_configure_append() { |
| 29 | cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/libgphoto2_port/po/ |
| 30 | cd ${S}/libgphoto2_port/ |
| 31 | autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths |
| 32 | cd ${S} |
| 33 | } |
| 34 | |
| 35 | do_install_append() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | install -d ${D}${sysconfdir}/udev/rules.d/ |
| 37 | install -m 0755 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/ |
| 38 | } |
| 39 | |
| 40 | PACKAGES =+ "libgphotoport libgphoto2-camlibs" |
| 41 | FILES_libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*" |
| 42 | RRECOMMENDS_${PN} = "libgphoto2-camlibs" |
| 43 | |
| 44 | FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*" |
| 45 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame] | 46 | FILES_${PN} += "${nonarch_base_libdir}/udev/*" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 47 | FILES_${PN}-dbg += "${libdir}/*/*/.debug" |
| 48 | FILES_${PN}-dev += "${libdir}/*/*/*.la" |
| 49 | FILES_${PN}-doc += "${datadir}/libgphoto2_port/0.12.0/vcamera/README.txt" |