Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 1 | HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags" |
| 2 | SUMMARY = "Hardware Diagnostics for POWER Systems" |
Brad Bishop | fac997f | 2020-02-03 17:09:22 -0500 | [diff] [blame] | 3 | |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 4 | DESCRIPTION = \ |
| 5 | "In the event of a system fatal error reported by the internal system \ |
| 6 | hardware (processor chips, memory chips, I/O chips, system memory, etc.), \ |
| 7 | POWER Systems have the ability to diagnose the root cause of the failure \ |
| 8 | and perform any service action needed to avoid repeated system failures." |
| 9 | |
| 10 | PV = "0.1+git${SRCPV}" |
Brad Bishop | fac997f | 2020-02-03 17:09:22 -0500 | [diff] [blame] | 11 | LICENSE = "Apache-2.0" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 13 | |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 14 | inherit meson systemd |
Brad Bishop | fac997f | 2020-02-03 17:09:22 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 18 | SRC_URI = "git://github.com/openbmc/openpower-hw-diags" |
Andrew Geissler | 0a3c468 | 2021-03-26 16:30:25 +0000 | [diff] [blame] | 19 | SRCREV = "982f172262693198f649d4d8918e5defb1ff6c9c" |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 20 | |
| 21 | SYSTEMD_SERVICE_${PN} = "attn_handler.service" |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 22 | |
Zane Shelley | b6d95ee | 2021-02-10 17:43:44 -0600 | [diff] [blame] | 23 | DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \ |
| 24 | nlohmann-json" |
| 25 | |
Zane Shelley | 8dff99b | 2020-11-10 19:56:40 -0600 | [diff] [blame] | 26 | # This is required so that libhei is installed with the chip data files. |
| 27 | RDEPENDS_${PN} += "openpower-libhei" |
Zane Shelley | aa8acf1 | 2021-03-23 17:13:08 -0500 | [diff] [blame^] | 28 | |
| 29 | # Conditionally pull in PHAL APIs, if available. |
| 30 | PACKAGECONFIG ??= "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" |
| 31 | PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, pdata" |
| 32 | |