Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 1 | LICENSE = "Apache-2.0" |
Andrew Geissler | e11f5e2 | 2021-07-20 18:10:59 +0000 | [diff] [blame] | 2 | LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e" |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 3 | DEPENDS = " \ |
| 4 | openssl \ |
| 5 | zlib \ |
| 6 | boost \ |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 7 | libpam \ |
| 8 | sdbusplus \ |
| 9 | gtest \ |
| 10 | nlohmann-json \ |
| 11 | libtinyxml2 \ |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 12 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \ |
| 13 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \ |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 14 | " |
Andrew Geissler | aab6024 | 2023-01-19 14:20:27 -0600 | [diff] [blame^] | 15 | SRCREV = "7b395d7c9538360f8b034481fedcdeb5d3ee784b" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 16 | PV = "1.0+git${SRCPV}" |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 17 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 18 | SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https;nobranch=1" |
| 19 | SRC_URI += " \ |
| 20 | file://run-ptest \ |
Ed Tanous | 07f48cc | 2021-02-22 10:49:30 -0800 | [diff] [blame] | 21 | " |
Adriana Kobylak | 7e0ff54f | 2018-12-13 11:01:05 -0600 | [diff] [blame] | 22 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 23 | S = "${WORKDIR}/git" |
| 24 | SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket" |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 25 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 26 | inherit systemd |
| 27 | inherit useradd |
| 28 | inherit pkgconfig meson ptest |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 29 | |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 30 | EXTRA_OEMESON = " \ |
| 31 | --buildtype=minsize \ |
| 32 | -Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \ |
Ed Tanous | a443c54 | 2021-02-26 13:28:37 -0800 | [diff] [blame] | 33 | " |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 34 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 35 | do_install_ptest() { |
| 36 | install -d ${D}${PTEST_PATH}/test |
| 37 | cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/ |
| 38 | } |
Ed Tanous | 2c2a1c5 | 2018-01-29 10:56:52 -0800 | [diff] [blame] | 39 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 40 | RDEPENDS:${PN} += " \ |
| 41 | jsnbd \ |
Patrick Williams | 0450a02 | 2022-10-07 21:23:47 -0500 | [diff] [blame] | 42 | phosphor-objmgr \ |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 43 | " |
| 44 | |
| 45 | FILES:${PN} += "${datadir}/** " |
| 46 | |
| 47 | USERADD_PACKAGES = "${PN}" |
| 48 | # add a user called httpd for the server to assume |
| 49 | USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb" |
| 50 | |
| 51 | GROUPADD_PARAM:${PN} = "web; redfish" |
Manojkiran Eda | f1f2e24 | 2020-09-02 21:48:12 +0530 | [diff] [blame] | 52 | FULL_OPTIMIZATION = "-Os " |