blob: 3f7bf2bf04d4df5696b7b2de49f1c0dc4586bc0c [file] [log] [blame]
Sergey Solominaac4adf2016-11-28 15:03:24 -06001SUMMARY = "POWER9 start host"
2DESCRIPTION = "Service to start POWER9 IPL through SBE"
3PR = "r1"
4
5inherit obmc-phosphor-systemd
6inherit obmc-phosphor-license
7
8FILESEXTRAPATHS_prepend := "${THISDIR}/op-pdbg-host-control:"
9
10PROVIDES += 'virtual/obmc-host-ctl'
11RPROVIDES_${PN} += 'virtual-obmc-host-ctl'
12
13RDEPENDS_${PN} += "pdbg \
14 p9-vcs-workaround"
15
16S = "${WORKDIR}"
17SRC_URI += "file://start_host.sh"
18
19do_install() {
20 install -d ${D}${bindir}
21 install -m 0755 ${WORKDIR}/start_host.sh \
22 ${D}${bindir}/start_host.sh
23}
24
25TMPL = "start_host@.service"
26INSTFMT = "start_host@{0}.service"
27TGTFMT = "obmc-chassis-start@{0}.target"
28FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
29
30SYSTEMD_SERVICE_${PN} += "${TMPL}"
31SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
32SYSTEMD_SUBSTITUTIONS += "MACHINE:${MACHINE}:${TMPL}"