Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenDNSSEC is a policy-based zone signer that automates the process of keeping track of DNSSEC keys and the signing of zones" |
| 2 | |
| 3 | LICENSE = "BSD" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b041dbe2da80d4efd951393fbba90937" |
| 5 | |
| 6 | DEPENDS = "libxml2 openssl ldns libmicrohttpd jansson libyaml " |
| 7 | |
| 8 | SRC_URI = "git://github.com/opendnssec/opendnssec;branch=develop \ |
| 9 | file://libxml2_conf.patch \ |
| 10 | file://libdns_conf_fix.patch \ |
| 11 | file://fix_fprint.patch \ |
| 12 | " |
| 13 | |
| 14 | SRCREV = "5876bccb38428790e2e9afc806ca68b029879874" |
| 15 | |
| 16 | inherit autotools pkgconfig perlnative |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | EXTRA_OECONF = " --with-libxml2=${STAGING_DIR_HOST}/usr --with-ldns=${STAGING_DIR_HOST}/usr \ |
| 21 | --with-ssl=${STAGING_DIR_HOST}/usr " |
| 22 | |
| 23 | CFLAGS += "-fcommon" |
| 24 | |
| 25 | PACKAGECONFIG ?= "sqlite3" |
| 26 | |
| 27 | PACKAGECONFIG[cunit] = "--with-cunit=${STAGING_DIR_HOST}/usr, --without-cunit," |
| 28 | PACKAGECONFIG[sqlite3] = "--with-sqlite3=${STAGING_DIR_HOST}/usr, ,sqlite3, sqlite3" |
| 29 | PACKAGECONFIG[mysql] = "--with-mysql=yes, , mariadb, mariadb" |
| 30 | PACKAGECONFIG[readline] = "--with-readline, --without-readline, readline" |
| 31 | PACKAGECONFIG[unwind] = "--with-libunwind, --without-libunwind" |
| 32 | |
| 33 | do_install_append () { |
| 34 | rm -rf ${D}${localstatedir}/run |
| 35 | } |
| 36 | |
| 37 | RDEPENDS_${PN} = "softhsm" |