Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require libtool-${PV}.inc |
| 2 | |
| 3 | DEPENDS = "" |
| 4 | |
| 5 | SRC_URI += "file://prefix.patch" |
| 6 | |
| 7 | inherit native |
| 8 | |
| 9 | EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}" |
| 10 | |
| 11 | do_configure_prepend () { |
| 12 | # Remove any existing libtool m4 since old stale versions would break |
| 13 | # any upgrade |
| 14 | rm -f ${STAGING_DATADIR}/aclocal/libtool.m4 |
| 15 | rm -f ${STAGING_DATADIR}/aclocal/lt*.m4 |
| 16 | } |
| 17 | |
| 18 | do_install () { |
| 19 | autotools_do_install |
| 20 | install -d ${D}${bindir}/ |
| 21 | install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool |
| 22 | } |