Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "The Cairo 2D vector graphics library" |
| 2 | DESCRIPTION = "Cairo is a multi-platform library providing anti-aliased \ |
| 3 | vector-based rendering for multiple target backends. Paths consist \ |
| 4 | of line segments and cubic splines and can be rendered at any width \ |
| 5 | with various join and cap styles. All colors may be specified with \ |
| 6 | optional translucence (opacity/alpha) and combined using the \ |
| 7 | extended Porter/Duff compositing algebra as found in the X Render \ |
| 8 | Extension." |
| 9 | HOMEPAGE = "http://cairographics.org" |
| 10 | BUGTRACKER = "http://bugs.freedesktop.org" |
| 11 | SECTION = "libs" |
| 12 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 13 | LICENSE = "(MPL-1.1 | LGPLv2.1) & GPLv3+" |
| 14 | LICENSE_${PN} = "MPL-1.1 | LGPLv2.1" |
| 15 | LICENSE_${PN}-dev = "MPL-1.1 | LGPLv2.1" |
| 16 | LICENSE_${PN}-doc = "MPL-1.1 | LGPLv2.1" |
| 17 | LICENSE_${PN}-gobject = "MPL-1.1 | LGPLv2.1" |
| 18 | LICENSE_${PN}-script-interpreter = "MPL-1.1 | LGPLv2.1" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | LICENSE_${PN}-perf-utils = "GPLv3+" |
| 20 | |
| 21 | LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77" |
| 22 | |
| 23 | DEPENDS = "fontconfig glib-2.0 libpng pixman zlib" |
| 24 | |
| 25 | SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz \ |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 26 | file://cairo-get_bitmap_surface-bsc1036789-CVE-2017-7475.diff \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | file://CVE-2018-19876.patch \ |
| 28 | file://CVE-2019-6461.patch \ |
| 29 | file://CVE-2019-6462.patch \ |
| 30 | " |
| 31 | |
| 32 | SRC_URI[md5sum] = "f19e0353828269c22bd72e271243a552" |
| 33 | SRC_URI[sha256sum] = "5e7b29b3f113ef870d1e3ecf8adf21f923396401604bda16d44be45e66052331" |
| 34 | |
| 35 | inherit autotools pkgconfig upstream-version-is-even gtk-doc multilib_script |
| 36 | |
| 37 | MULTILIB_SCRIPTS = "${PN}-perf-utils:${bindir}/cairo-trace" |
| 38 | |
| 39 | X11DEPENDS = "virtual/libx11 libsm libxrender libxext" |
| 40 | |
| 41 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'directfb', d)} \ |
| 42 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 43 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'opengl', '', d)} \ |
| 44 | trace" |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 45 | PACKAGECONFIG_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)}" |
| 46 | PACKAGECONFIG_class-nativesdk = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 47 | |
| 48 | PACKAGECONFIG[x11] = "--with-x=yes -enable-xlib,--with-x=no --disable-xlib,${X11DEPENDS}" |
| 49 | PACKAGECONFIG[xcb] = "--enable-xcb,--disable-xcb,libxcb" |
| 50 | PACKAGECONFIG[directfb] = "--enable-directfb=yes,,directfb" |
| 51 | PACKAGECONFIG[valgrind] = "--enable-valgrind=yes,--disable-valgrind,valgrind" |
| 52 | PACKAGECONFIG[egl] = "--enable-egl=yes,--disable-egl,virtual/egl" |
| 53 | PACKAGECONFIG[glesv2] = "--enable-glesv2,--disable-glesv2,virtual/libgles2" |
| 54 | PACKAGECONFIG[opengl] = "--enable-gl,--disable-gl,virtual/libgl" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 55 | PACKAGECONFIG[trace] = "--enable-trace,--disable-trace" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 56 | |
| 57 | EXTRA_OECONF += " \ |
| 58 | ${@bb.utils.contains('TARGET_FPU', 'soft', '--disable-some-floating-point', '', d)} \ |
| 59 | --enable-tee \ |
| 60 | " |
| 61 | |
| 62 | # We don't depend on binutils so we need to disable this |
| 63 | export ac_cv_lib_bfd_bfd_openr="no" |
| 64 | # Ensure we don't depend on LZO |
| 65 | export ac_cv_lib_lzo2_lzo2a_decompress="no" |
| 66 | |
| 67 | do_install_append () { |
| 68 | rm -rf ${D}${bindir}/cairo-sphinx |
| 69 | rm -rf ${D}${libdir}/cairo/cairo-fdr* |
| 70 | rm -rf ${D}${libdir}/cairo/cairo-sphinx* |
| 71 | rm -rf ${D}${libdir}/cairo/.debug/cairo-fdr* |
| 72 | rm -rf ${D}${libdir}/cairo/.debug/cairo-sphinx* |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 73 | [ ! -d ${D}${bindir} ] || |
| 74 | rmdir -p --ignore-fail-on-non-empty ${D}${bindir} |
| 75 | [ ! -d ${D}${libdir}/cairo ] || |
| 76 | rmdir -p --ignore-fail-on-non-empty ${D}${libdir}/cairo |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 77 | } |
| 78 | |
| 79 | PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils" |
| 80 | |
| 81 | SUMMARY_cairo-gobject = "The Cairo library GObject wrapper library" |
| 82 | DESCRIPTION_cairo-gobject = "A GObject wrapper library for the Cairo API." |
| 83 | |
| 84 | SUMMARY_cairo-script-interpreter = "The Cairo library script interpreter" |
| 85 | DESCRIPTION_cairo-script-interpreter = "The Cairo script interpreter implements \ |
| 86 | CairoScript. CairoScript is used by tracing utilities to enable the ability \ |
| 87 | to replay rendering." |
| 88 | |
| 89 | DESCRIPTION_cairo-perf-utils = "The Cairo library performance utilities" |
| 90 | |
| 91 | FILES_${PN} = "${libdir}/libcairo.so.*" |
| 92 | FILES_${PN}-gobject = "${libdir}/libcairo-gobject.so.*" |
| 93 | FILES_${PN}-script-interpreter = "${libdir}/libcairo-script-interpreter.so.*" |
| 94 | FILES_${PN}-perf-utils = "${bindir}/cairo-trace* ${libdir}/cairo/*.la ${libdir}/cairo/libcairo-trace.so" |
| 95 | |
| 96 | BBCLASSEXTEND = "native nativesdk" |
| 97 | |
| 98 | UPSTREAM_CHECK_REGEX = "cairo-(?P<pver>\d+(\.\d+)+).tar.xz" |