Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "ITS Tool allows you to translate your XML documents with PO files" |
| 2 | HOMEPAGE = "http://itstool.org/" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5" |
| 5 | |
| 6 | inherit autotools python3native |
| 7 | |
| 8 | DEPENDS = "libxml2-native" |
| 9 | |
| 10 | SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2" |
| 11 | SRC_URI_append_class-native = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch" |
| 12 | SRC_URI_append_class-nativesdk = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch" |
| 13 | SRC_URI_append_class-target = " file://0002-Don-t-use-build-time-hardcoded-python-binary-path.patch" |
| 14 | |
| 15 | SRC_URI[md5sum] = "4306eeba4f4aee6b393d14f9c3c57ca1" |
| 16 | SRC_URI[sha256sum] = "6233cc22726a9a5a83664bf67d1af79549a298c23185d926c3677afa917b92a9" |
| 17 | |
| 18 | BBCLASSEXTEND = "native nativesdk" |
| 19 | |
| 20 | RDEPENDS_${PN} += "libxml2-python" |