Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Downloads, builds, installs, upgrades, and uninstalls Python packages" |
| 2 | HOMEPAGE = "https://pypi.python.org/pypi/setuptools" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "Python-2.0 | ZPL-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e" |
| 6 | |
| 7 | SRCNAME = "setuptools" |
| 8 | |
| 9 | PROVIDES = "python-distribute" |
| 10 | |
| 11 | DEPENDS += "python" |
| 12 | DEPENDS_class-native += "python-native" |
| 13 | |
| 14 | inherit distutils |
| 15 | |
| 16 | SRC_URI = "https://pypi.python.org/packages/source/s/setuptools/setuptools-${PV}.tar.gz" |
| 17 | SRC_URI[md5sum] = "52b4e48939ef311d7204f8fe940764f4" |
| 18 | SRC_URI[sha256sum] = "0994a58df27ea5dc523782a601357a2198b7493dcc99a30d51827a23585b5b1d" |
| 19 | |
| 20 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 21 | |
| 22 | |
| 23 | DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages" |
| 24 | |
| 25 | do_install_prepend() { |
| 26 | install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages |
| 27 | } |
| 28 | |
| 29 | RDEPENDS_${PN} = "\ |
| 30 | python-stringold \ |
| 31 | python-email \ |
| 32 | python-shell \ |
| 33 | python-distutils \ |
| 34 | python-compression \ |
| 35 | " |
| 36 | |
| 37 | RDEPENDS_${PN}_class-native = "\ |
| 38 | python-distutils \ |
| 39 | python-compression \ |
| 40 | " |
| 41 | |
| 42 | RREPLACES_${PN} = "python-distribute" |
| 43 | RPROVIDES_${PN} = "python-distribute" |
| 44 | RCONFLICTS_${PN} = "python-distribute" |
| 45 | |
| 46 | BBCLASSEXTEND = "native nativesdk" |