Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| 3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| 4 | LICENSE = "LGPLv2.1 & GPLv2 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \ |
| 6 | file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \ |
| 7 | file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad" |
| 8 | |
| 9 | inherit module |
| 10 | |
| 11 | SRCREV = "7a88f8b50696dd71e80c08661159caf8e119bf51" |
| 12 | PV = "2.6.2+git${SRCPV}" |
| 13 | |
| 14 | COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|arm).*-linux' |
| 15 | |
| 16 | SRC_URI = "git://git.lttng.org/lttng-modules.git;branch=stable-2.6" |
| 17 | |
| 18 | export INSTALL_MOD_DIR="kernel/lttng-modules" |
| 19 | |
| 20 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | do_install_append() { |
| 25 | # Delete empty directories to avoid QA failures if no modules were built |
| 26 | find ${D}/lib -depth -type d -empty -exec rmdir {} \; |
| 27 | } |
| 28 | |
| 29 | python do_package_prepend() { |
| 30 | if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')): |
| 31 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True)) |
| 32 | } |
| 33 | |