Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Initscript for enabling USB gadget Ethernet" |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 2 | DESCRIPTION = "This module allows ethernet emulation over USB, allowing for \ |
| 3 | all sorts of nifty things like SSH and NFS in one go plus charging over the \ |
| 4 | same wire, at higher speeds than most Wifi connections." |
| 5 | HOMEPAGE = "http://linux-sunxi.org/USB_Gadget/Ethernet" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe" |
| 9 | |
| 10 | PR = "r3" |
| 11 | |
| 12 | SRC_URI = "file://usb-gether \ |
| 13 | file://COPYING.GPL" |
| 14 | S = "${WORKDIR}" |
| 15 | |
| 16 | do_install() { |
| 17 | install -d ${D}${sysconfdir} |
| 18 | install -d ${D}${sysconfdir}/init.d |
| 19 | install usb-gether ${D}${sysconfdir}/init.d |
| 20 | } |
| 21 | |
| 22 | inherit update-rc.d allarch |
| 23 | |
| 24 | INITSCRIPT_NAME = "usb-gether" |
| 25 | INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ." |